Question regarding Mac Builds and Tile-sets

 So I have been trying to find the latest up to date Mac build (whether stable or experimental) that actually runs. I tried to download the stable build from the front page but it wouldn't work for me. Also if possible I would really like to use the "HRose's Retro TileSet" if possible, so if anyone knows how to use it (or has ever used it) on a Mac, feel free to let me know. Thanks so much, and happy 4th!

I used Wine Bottler to create a working version of one of last month’s Experimentals (can’t remember which) and it seems to be working fine. It’s pretty easy, you just have to remember not to place the bottle in the file being bottled (shockingly easy to do by default.) Turns out recursive bottling takes an infinite amount of processing time… I call it Klein Bottling.

Hrose’s retro? I guess you mean Retrodays? Great choice! I will ease you a link into the thread where you can get it!

(Though, if you download the Tiles version, this tileset already comes with the game. Go to options, graphics, and then choose the tileset!)

So how exactly do I use Wine bottler? Could you walk me through it maybe?
Would I just download the windows latest experimental TileSet and try to run it through the program?

If you donwload the tiles (SDL) version, yes. Curses does not have tileset support.

We really need somebody to make more reliable Mac builds. If you have a reliably working tiles version please add it here: (I have no mac, so I cannot test if it works).

Wine ( is a windows emulator which works on Mac as well as Linux. I’ve never tried it though but I think you can try to run the windows build (SDL version if you need the tiles) through it. Though there’s no guarantee it will work as I don’t have a mac atm.

It’s on my list after I’ve gotten CMake working reliably on Windows. Judging by the #cdda-dev response, my existing fixes haven’t done much - probably, for both build systems, we’ll have to figure out some way of ensuring the PATH is set properly, and that’s a bear for everyone involved.

Have you tried using Homebrew? It seems to work for me and allows me to access both the experimental and the Retrodays tileset. Try using the method here.

I’ve got a reliable Mac build going on for experimental. See