Playing WIN/Tiles on Mac with Wine? Was working, now screen is blue

Not an issue with CDDA directly, but playing windows/tiles on MacOS via Wine.

I felt really proud of myself having linked up my active x64 game on windows, with the world/save folder syncing via dropbox, and then able move seamlessly between my home Win10 machine, my win10 laptop, then my work Macbook. Then something went weird with the display/font on the Mac (crushed/grainy text), and I thought I’d try to use PlayOnMac and try a true virtual app to fix it. Didn’t work, and I’ve tried removing it all except for plain Wine (installed via terminal/homebrew).

Trying a fresh download of CDDA its still launching blue, but the controls work (hitting Q exits, etc.), so I must have created a wine config somewhere that’s now permanently affecting my ability to run it.

Anyone else running CDDA this way?

I have a very similar problem - i have black screen and nothing else on it, no menu, nothing, just black screen BUT when i move arrows i can hear sounds of switching from one menu option to another, i tried using the launcher (by the way, you are using the newest launcher version or the one from 2017, because i’m using the older version cause newer has some critical bug on mac that does not let me launch it through wine), now i’m trying to do it manually, still trying.

But i swear, it launched and played before through wine, i swear, i remember this, i have not even updated my mac version, nothing has changed.Maybe the thing is with the new versions?Because if you try to install the original 0.C version through wine it works, but there is some messed up bug with menu option names, everything is gibberish.It’s not wine, surely it is not it because it ran on older versions under the same circumstances (wine configurations).

–I didn’t really read much of it, as all I wanted to ask really quick was this: what is Wine? Of course, I know what the drink is, but you obviously aren’t talking about that. You needn’t a really long explanation, just something simple and short.

Just tried to launch the latest ASCII version through wine - worked PERFECTLY with no gibberish in the menu or any bugs, but the tiles version - still nope.So the deal is with the newest experimental builds.

Wine is short for Wineskin - it is a free app that allows to activate any exe file whether you’re on Mac or Linux, sort of emulating windows, you can do it by installing one of different versions of Wineskin engines and then making a “wrapper” based on that engine, once you’ve done that you open the wrapper and launch whatever exe file you want through it, it’s running an app inside of an app - exactly this.

It is very reliable and has proven to work in many, many cases for many Mac-or-Linux-non-compatible games (google “games that run on wine”, but it’s easier to play other games through GoG and not Steam, because Steam is kinda trickier to launch).

Too bad that Mac versions of CDDA don’t work, so now we’ll have to wait for new experimental builds to fix this glitch, i truly hope that it will get more attention cause it’s really annoying (i have not played this for more than a year, was busy with life, now when i installed all kinds of mods turning this game into an awesome fallout-minecraft-sims-skyrim-doom-ark mumbo-jumbo it just…does not launch).

Shoot – I wonder what recent build(s) “broke” it? I was keeping the install up to date via the launcher on Windows, then just copying the folders by hand to the mac.

There’s a trick to add an environment variable to get the launcher to work, but I just skipped that and ran the cataclysm-tiles.exe file directly. It worked through a few version updates until recently stopping. I suppose I can just download a version from a week or so ago, and see if there’s a point where it stops working at a specific change.

Beetlecat, you think they’ll fix it?I’m kinda stressed out, really wanted to enjoy all the new and fun stuff, now have to wait, no idea how long.If, by any chance, you find one of your old versions that worked, could you somehow post it here as a link to download?That would be awesome.

I have version 0.7081 of the Mac Graphical, which works on my mid-2015 Mac, running the latest version of OSX. I took a hiatus and it broke sometime after that, but I can’t tell you more accurately than that. Anybody manage to get a later version to run?

We’re talking two different things now. I’m attempting to run the current win/tiles experimentals with WINE – and it only recently stopped working for me.

So…i guess that we’ll have to wait for newer experimental builds, i’m not sure whether this complaint thread will attract attention of the ones who work on making experimental versions, but i think i remember that some old experimental versions at times did not launch on wine as well, some did, so it’s random.

GUYS, i found June of 2018 experimental version of CDDA, it works flawlessly on my mac, the only problem is that it has no sound, in order to make it actually playable, turn on the “Full screen” mode in options.Here’s the link to the thread with the old version, it’s at the very end of the post.

–Huh, thanks for the info. I may-or-may-not try that at some point then, although I’d probably prefer to just install windows onto a mac instead. Although not in linux. I don’t use that.
P.S. try not to go on too much of a tangent by complaints of me not caring in the slightest for Linux :expressionless:

1 Like

A mini-followup now that I’ve had a moment to come back to fiddling with it – the Win64 Tiles version (latest) works fine if you set the graphics options to fullscreen before launching with WINE. A fresh copy of the game doesn’t have the config/options.json file, but I just copied it from an older install, and edited the fullscreen setting before launching, and the game ran fine.

Now to get back to figuring out how to set the x64 environment variable to be able to use the Launcher. I love the auto-updater and saved game backup system. :slight_smile:

1 Like

No idea how you got it to work now, i changed settings in WINE to fullscreen, but now the newest experimental versions simply don’t launch at all, not even the black screen - WINE is simply unable to launch them.This will take longer than usual, lol, at least we have the June debug version.

I meant to say to set the game as fullscreen in its own settings. Not doing anything different with WINE. I actually don’t have any idea how to tweak WINE at all – I installed it via command line/brew and just run the game exe with “wine cata…” :slight_smile:

1 Like

Wait, how do you access the settings json file?I can’t find it on my Mac debug version.

in the win64 version, there’s a /config/options.json file. Just search for “fullscreen” and make the change near there.

I’m hoping to one day run the launcher version of win64 on my macbook, but for the moment this works. All in the name of trying to share the world/saves between computers via a dropbox sync. :slight_smile:

1 Like