Tiles do not work on Mac in "Ma" version

Hi all,

I just downloaded the latest Mac build. Although it launches fine and lets me set all the parameters prior to world generation, it systematically crashes once I launch the world generation.

The error message I get says that “Cataclysm-tiles” has crashed… Any idea how to fix that? Am I the only one experiencing this? I’d really like to try out all the exciting new stuff ;).

I noticed that “use tiles” in options/graphics is turned on “Fasle” by default, don’t know whether this is normal. Also After the game has crashed, all the options are set back to default (including the “use tiles” to False if I try to set it to True before world generation). In any cases (“use tiles” True or False), the game crashes the same way…

So… Am I the only one having the problem? Anyone else having the game working properly on Mac?

I would imagine the problem here is that a lot of us do not use Macs, So I can’t really test it for you to see if I can figure anything out =S

What version of OS X do you have and which Mac build did you download? The first Mac build (labeled 10.7+) will only work on Lion or above. The 2nd one should work on older versions (Leopard, Snow Leipard).

Apparently I left my save folder in the bundle after testing the build, so that’s why the Tiles option is set to false by default (my preference).

I tested the 10.7+ compatible build on Mountain Lion (10.7.5) and the pre-10.7 build on a Snow Leopard machine. Those worked but there may be other issues to consider.

Need as much info from possible about your OS and which build you installed. Plus if there are other mac devs around who can help or collaborate, that would be welcome. I’m moonlighting.

If you have Mountain Lion (10.8) or above, you may have to install XQuartz (X11) for the current Mac build to work.

[quote=“pipehat, post:5, topic:4036”]If you have Mountain Lion (10.8) or above, you may have to install XQuartz (X11) for the current Mac build to work.



Great to get an answer :).

So, I got the latest build. I am on Mavericks, 10.9, and I installed an updated version of XQuartz, precisely so that Cataclysm would work…

Could this come from Mavericks :(?

Did installing XQuartz fix the problem for you? If so, great!

Apparently Apple stopped including X11 (what XQuartz implements) starting with Mountain Lion (10.8).

Probably we can eliminate the X11 dependency in future builds. I think it has to do with the version of the sdl libs I compiled against.

No, I meant I installed Xquartz only to play Cataclysm, but unfortunately, this did not solve the reported problem: I simply could not open Cataclysm prior to Xquartz installation. Now I can, but I have the report issue with “Cataclysm-tiles”…

I installed XQuartz because Apple said that was basically the only solution to get X11 from now on. Is there a possibility to install X11 directly instead? Would that solve my problem?

Thanks for the Mac support :).

As far as I know, XQuartz is the X11 implementation for Mac at this point.

I think we just need a Mac build that uses the SDL framework libraries - or maybe a custom build of the homebrew sdl libs that uses only Cocoa and not Carbon.

I’ll try to mess with that when time permits (weekend).

Thats’s also my understanding of X11 / XQuartz…

Regarding the use of other libs, it might be solution. I was actually surprised that this build uses X11, as it seems to me that I didn’t need XQuartz to run Cataclysm before, even on the Romero build which already included tiles…

I know the Romero build used SDL. The other thing that might be an issue is 32 vs 64 bit machines.

My build was 64-bit. What’s your system Nioshy?

For an example of how to check, if needed: http://support.apple.com/kb/ht3696

I have a 64 bit system as well…

An news on this front?

Hi, I have a Mac laptop and a PC desktop and I am just running the stable 0.9 Ma windows version in Wineskin. So try that if the tiles version doesn’t work.

I am running 10.6.8 Mac OS, and there is a pre and post-10.7 Mac version available from the main website. So my input only really counts for the pre-10.7 version.

I downloaded and tried to run both versions anyway.
The post 10.7 one just crashes on opening.
The pre 10.7 one works with Hoder’s, Tsu’s, and Deon’s tilesets.

There’s my feedback, for what it’s worth. Might not be relevant.

P.S. So glad I switched back to Snow Leopard :wink:

Quick fix recommendation at this point is: if the existing Mac builds don’t work for you, try the windows one under wine.

I think the next step to try and increase build compatibility might be to have a Leopard / Xcode 3 build machine. I’m kind of hoping a more practiced mac focused dev will show up with advice. I’m standing by to assist and share knowledge if somebody wants to take the problem on to the next step.

My roommate is having the same crash on world gen, on Mac 10.6.8, and currently downloading Mavericks 10.9-or something… I’ll update after he tries again.

Edit: Maverick’s 10.9.1 is what he updated to, and after d/l’ing XQuartz, he’s able to run the Mac stable release using X11.