I believe I tried to take off a martial arts by accident and it put a None in my inventory. It’s glitchy and when it shares a key command with another item it makes it impossible to interact with said item.

It’s annoying.

Npcs can also hand you a none… but they are buggy so that’s to be expected.

We used to be able to remove a none from our inventory by activating it. Sadly this method no longer works for reasons I don’t understand.

Maybe this will work. Maybe. This method is untested but it can’t really do any worse.

Hold a few batteries, less then you need to fill a tool.
Use [=] to swap its letter with the none/blocked object.
Reload the tool to remove the batteries from your inventory.

This probably wont free up the slot the none will indefinably hold in your inventory but it should give you back the item that the none is blocking.

I don’t have the game here so let me know if it works.

I believe dropping the None from the '/'advanced inventory view will work.

I can confirm that worked! A word of advice, the “none” becomes an item when you drop it, so I recommend discarding it somewhere that you won’t stay. I dropped mine in the woods somewhere so I don’t have to look at it!

Try beating a jabberwock to death with it. Bonus points if you actually succeed. Double bonus points if you beat the NPC that gave you it (assuming it was an NPC) to do this quest to death.