Mod item tile issue

Have a mod, that doesn’t have a tile set, and doesn’t seem to have at least one of it’s item set with an actual tile for a vehicle part. So I have a big ugly ampersand sign in my vehicle. I want to get rid of it by changing the tile to look like something else.

I assume the looks_like json property should do this, and documentation on the modding seems to agree. But when I set the property it doesn’t seem to change the tile when I load up a saved game with it in it.

I’ve tried:
“looks_like”: “craft_rig”
Which I believe should make it look like the FOODCO Buddy, I’ve tried “f_sink” which is what the FOODCO buddies tag looks like, I’ve tried using other vehicle part IDs, like the welding rig, all with no success, it simply remains an ugly orange ampersand.

Anyone know what’s wrong, how I can address it? If it helps I’m also using the Undead People tileset from SomeDeadGuy.


Hm, is it possible that you’ve accidentally used the looks_like tag on the item (if it’s something that has an item form) instead of the vehicle part?
As an example, you’ve set the looks_like tag on spiked_plate (which is the item used to install into a vehicle) instead of plating_spiked (which is the installed vehicle part with the same name).

Pretty sure, since the “type” property says “vehicle_part”, here’s a paste:

"type": "vehicle_part",
"id": "surv_station_t",
"//": "Almost all utilities in one!",
"name": "survivor's station unit",
"description": "A makeshift vehicle mountable station comprised of many utilities, all compressed into a single unit.  Combines the functionality of a vehicle kitchen unit, forge, welder, chemistry set, and all of the myriad functions of the FOODCO kitchen buddy.  As a consequence, it leaves no space left for storage.",
"symbol": "&",
"looks_like": "craft_rig",
"color": "light_red",
"broken_symbol": "x",
"broken_color": "light_red",
"damage_modifier": 80,
"durability": 100,
"item": "surv_station",
"difficulty": 6,
"location": "center",
"breaks_into": [
  { "item": "steel_lump", "count": [ 30, 40 ] },
  { "item": "steel_chunk", "count": [ 30, 40 ] },
  { "item": "scrap", "count": [ 30, 40 ] },
  { "item": "circuit", "count": [ 30, 40 ] },
  { "item": "e_scrap", "count": [ 30, 40 ] },
  { "item": "amplifier", "count": [ 30, 40 ] }


So I’m completely at a loss here.

Hm, do you use Malkeus' Preferences (Malkeus_Enhancement_Mod)?

Because if you do, you’ll have to set the looks_like tag in that mod ( in the Upgraded_Survivor_Station_Unit_SURVIVORMOD.json file).

If you don’t… Then I don’t know what else it could be…
I guess you’ve restarted the game after the change?

@Valase nope. Not sure what was wrong, but I tried a clean install of the all the mods, and edited it again, and it works now for whatever reason. So weird.

Well, at least you got it fixed :slight_smile: .

1 Like

@Valase indeed. I always find with games like this I always have more problems than the average person. Part of it is I’m sure my desire to mod all the things, but other is just bad luck.