Linux Starting Up

So, I haven’t had Linux for long. Fairly new to it. Now when I try to run Cataclysm via
I get this in return
./cataclysm-launcher: 19: exec: ./cataclysm-tiles : not found

I’m not sure the launcher works on linux, if I recall correctly it’s mostly for mac. (solution, try running “./cataclysm-tiles” directly)
Alternately, you might have the curses version (solution, try running “./cataclysm”)

Ah, fell asleep for a good hour and a half…
I tried to run
The result is
bash: ./cataclysm-tiles No such file or directory
Also I was using the Launcher earlier. I just had to reinstall the OS after my mate screwed this one up.

So after browsing through Google and a lot of forums…
I got it, in the end.
Installing a package file for 32 bit systems… Packages always fail for me unless I use the sudo apt-get install -package here- command. Which sucks cause I never know the exact name. Thats why it too so long. Then the same scenario for the lua packages…
Note I am using Ubuntu Linux Mint.
For the 32 bit systems.
sudo apt-get install ia32-libs
(This gave me errors so I then)
sudo apt-get update
(When that finished I did)
sudo apt-get install ia32-libs
(This time it worked perfectly.)
For Lua
sudo apt-get install liblua5.1-0:i386

Since then, I can run the game via ./cataclysm-launcher or ./cataclysm-tiles