Cataclysm on Linux help [Warning - Linux moron]

- The Garage may not be the best place for this, feel free to move me! -

Currently attempting to learn Linux, so I put Linux Mint on my secondary computer, I know only the basic stuff and some terminal commands. Not enough to really consider myself to know what i’m doing.

I just want to have Cataclysm on there as my friend that uses the computer that’s setup next to mine is trying to learn Cataclysm, and using Wine for it always creates a problem somewhere, and somehow. I tried the guide on the wiki for getting Cataclysm going, but I not only could not figure out how to launch it, but i’m also pretty sure that there was a dependency somewhere that went wrong.
I am a complete idiot when it comes to Linux, so hopefully one of you gods like Kevin could give me step by step help with this.

tl;dr - Born to be Mild is an idiot and is not good with the Linux.

brb gotta go switch my username to “no such file or directory”

It’s way easy on linux, especially if you’re playing terminal mode.
Download the archive you want.
Unpack the archive somewhere.
Open a terminal.
cd into the directory where you unpacked the archive.

If you want to play the tiles version, you need to get the right version of SDL installed.


Okay as far as I got was cd into the current directory. Now im just sitting in a Cataclysm-DDA directory with everything unpacked there with no clue what to do. Currently searching google trying to figure out what im doing.

I think I should invest in a Linux for Dummies book soon.

EDIT: Everything I have tried has returned “no such file or directory” even though I am sitting in the cataclysm directory I made.

EDIT2: tried sudo ./cataclysm-launcher enters password “command not found”

holy edits batman: I tried building it myself via terminal also, bringing me to the same point where I just would sit there in the directory trying to figure out how to run cataclysm or cataclysm-launcher. Ya know over in Windows-land we call this a double click.

EDIT4: somebody send a Linux rescue team

EDIT2: tried sudo ./cataclysm-launcher *enters password* "command not found"
Please don't do sudo. There is no need to run the game as root.

Usually the game is started like this (from the cataclysm folder):


If that does not work, enter


That shows the content of the current directory. If you’re in the right directory, you should see filenames like
[tt]CataclysmWin.cbp[/tt], [tt]LICENSE.txt[/tt], [tt][tt], [tt][/tt], and [tt]data[/tt].

EDIT: Everything I have tried has returned "no such file or directory" even though I am sitting in the cataclysm directory I made.

That either means you’re in the wrong directory or you didn’t wrote the correct command. Therefor, please tell what exactly you have done. What command did you enter and what was the result?

I think I should invest in a Linux for Dummies book soon.
There are plenty of tutorials online, or so I've heard (-;

okay there was a sub folder…

now im in the correct directory, ./cataclysm, it returns “error while loading shared libraries: cannot open a shared object file: No such file or directory”

So it looks like I have lua issues? This is almost a completely fresh install, all I have is Counter-Strike, Eclipse, and Java on this thing.

Sounds like you need to install the lua package.
Try after installing lua with:


PS. Only one of the two is correct, but i have not mint to check it. I’m rooting for the 2nd though.

PS2. If lua is already installed but cata still errors out, try building cata yourself.

  1. Download the source.
  2. Open a terminal, go to the source folder (cd), then build it with typing either make
    or make TILES=1 for tiles version.

See here for more. Ubuntu way should be the same for mint.:

Yeah I ended up having to build myself but we have liftoff!
Cataclysm has launched!

  • A wonderful moment -

Mostly because its the first time I have done something with Linux without anything catching on fire.

“This mod requires lua but your build does not support it”

c: eye twitch

[quote=“Born_tobe_Mild, post:10, topic:10587”]"This mod requires lua but your build does not support it"
c: eye twitch[/quote]
You have to build the CDDA with LUA=1 option: make LUA=1
If your liblua version is less then 5.2 then you can download the lib from here:
(I’m using CentOs 7 and it’s comes with 5.1 lua)

Well it was claiming that I had no Lua installed when I did have 5.2.3, I did some dicking around with it and suddenly its all happy with make Lua=1

I did make lua=1
went off without a hitch
start game.
Your build doesnt support lua.

oh god I was told this was easy I am not good with computer now.

please, on a terminal write:

and tell us the result.

As latogato said, you have to build with [tt]LUA=1[/tt] (all uppercase letters), [tt]Lua=1[/tt] or [tt]lua=1[/tt] wont work.

make LUA=1 returns that I dont have lua installed, doing lua -v returns that I have Lua 5.2.3, so I clearly have lua installed.

This is weird.
I’m not very good with makefile code, but by reading the makefile i’d think that your lua should be detected, based on this:

LUA_CANDIDATES = lua5.2 lua-5.2 lua5.1 lua-5.1 lua LUA_FOUND = $(firstword $(foreach lua,$(LUA_CANDIDATES),\ $(shell if $(PKG_CONFIG) --silence-errors --exists $(lua); then echo $(lua);fi))) LUA_PKG += $(if $(LUA_FOUND),$(LUA_FOUND),$(error "Lua not found by $(PKG_CONFIG), install it or make without 'LUA=1'"))

Which means (if i understand correctly): search serially for the lua variants (and we do know that the “lua” one exists), and if none exist, error out.
Maybe the problem is with pkg_config or its $PATH?

is this responding with “lua”?

Anyway, i do think you’d need someone with a bit more knowledge than me to debug it.

I threw that if statement into the terminal and it doesnt return anything.
There was no else in it so im assuming that means no lua on my system?

I think i got it here

If compiling software yourself, you should install not only the runtime (lua5.1) but also the development packages (liblua5.1-0-dev). That package contains the lua5.1.pc file.
this of course applies to the lua 5.2 that you are using

so you do need the pertinent lua5.2-dev package. try:

and then try to make it as BevapDin said.

It works.
It finally works.