Help me to make running it on Linux, please

Hello, since I hang up most of the time on my linux installation I wanted to have to have DDA here too. I don’t want the github clone because (I assume ) it is the tile version, but I 'd like to have the console version. I tried to download it and run bh cataclysm-launcher and just ./launcher and I always get the error

error while loading shared libraries: cannot open shared object file: No such file or directory

no matter what I do. I tried several libraries now.

This is my system

Linux xu64 3.13.0-46-generic #79-Ubuntu SMP Tue Mar 10 20:06:50 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Please help.

One, the launcher is really there for mac users, on linux ./cataclysm from the cataclysm directory should do it.
This doesn’t have anything to do with your problem, just a FYI.

Two, take a look at your /usr/lib directory, the lua library might just be named differently. If you have something along the lines of in there, do:

cd /usr/lib
sudo ln -s

What this does is create a symbolic link from the file the game is expecting ( to the file that exists on your system so that the game can find it.

didn’t help, I still have same error

Hello, now I did a search for that file and it is in


so it is definetelly there, but game still won’t start, any help?

I second this. Came there to create a similar thread. Liblua 5.2 installed, x86_64. I remember there was a similar issue several versions ago but it was related to some not having 64 bit version. I have it.

Interesting note: after creating a symbolic link /usr/lib/ to /usr/lib/x86_64-linux-gnu/ the error message changes to:

Does it mean I have to install a second x32 version of liblua5.2 ?

I did

, and cataclysm started working. But could you please make it use the normal x86_64 libraries? It shouldn’t be hard, at least 0.B used to work pretty well on x86_64 version of the liblua.

Ah, yes it looks like a 32 vs 64 bit thing, you either need 32 bit liblua, or install the 64 bit version from,Platform=Linux_x64/lastBuild/
or build yourself in 64-bit. I’ll take a look at releasing a 64 bit version in the future.

Ok to sum it up, you can do it in two ways:

1)Either do

on .deb based distros: Ubuntu/Mint/Debian

on .rpm based ones: Red Hat/Fedora/CentOS

or anything that will install i386 version of liblua5.2

2)Or go to here and get the latest tarball.

Maybe its just me being dumb but I cannot figure out how to download the archive from Kevin’s link.

Crap, sorry, I gave you a bad link, I forgot narc moved the downloads to a different server, it was causing problems because of some combination of the jenkins server having too much load from downloads and having its filesystem fill up with all the builds.

[quote author=burgerpro link=topic=9818.msg227663#msg227663 date=1426929157]
Ok to sum it up, you can do it in two ways:

1)Either do

on .deb based distros: Ubuntu/Mint/Debian

yeah, I tried that and now I get another error.

i would suggest compiling it yourself.
it will only take ~30 mins in a reasonably old machine (mine takes 20’ and is 5+ yrs old), and is as simple as running:


or whatever else you need, from within the top source directory.