"learned recipes" sometimes never get added to crafting menu

So for some reason even though I have nothing more I can learn from “trap and field” and my fabrication is above level 4 the under-slung recipe won’t appear. I’ve tried reading it even after completing twice over with “read once” and wielding it in my hands, but the recipe still won’t be added. Trying to use the filter “h:yes” to doesn’t work either.

This isn’t the first time its happened with some recipes either. Am I doing something wrong here? Why the heck won’t it appear?

You only learn skills from books when you read them. When crafting items from the recipes from the book, you need the book with the recipe in your sight range or inventory.

I have read it though. twice. and i’m holding it right in my hand

Hmmmmm… I remember recipes going missing when I already knew them. There was some sort of a keybind for hiding recipes in the craft menu. Mayhaps you accidentally hit that? I would doublecheck now, but I’m unable to at the moment.

I already said earlier checked my hidden recipes through “h:yes” filter to see if it was there, but still no luck

I am having a similar issue the difference is I am trying to craft the control laptop.

Do you play with the Salvaged Robots mod by any chance? Because said mod blacklists control laptops making many people who use it wonder why they can’t craft one.

You need level 5 mechanics (not fab) for it to appear.


I do. And I suspected it but I couldn’t find a blackliast file.

Ok I found the blacklist. It isn’t the salvaged robots mod but it is the modular turrets mod which it relies on.