Jury-Rigged Robots Mod

mod

#21

Bitchin. I think its time to finally bite the bullet and start a horde world!


#22

I still get debug messages when I try to use this. Can anyone else verify it currently works?


#23

I’ve released a few updates to bring it up date, and it works on my system. What kind of debug messages are you getting? Chances are I fixed something locally and neglected to post it here.


#24

Yeah unfortunately even when this is the only mod on the latest experimental it just explodes in debug messages.


#25

I can’t help if you don’t post the messages. The very first message is usually the real problem, the rest are due to the game not parsing the file past the initial error.

Did you include the updates from these two messages:
http://smf.cataclysmdda.com/index.php?topic=10667.msg264315#msg264315 <—Apply First
http://smf.cataclysmdda.com/index.php?topic=10667.msg267698#msg267698 <—Apply Second


#26

Here’s the debugs I get:


Before and after I applied those patches you replied with.


#27

Sorry for double post, I think the second image is not a mod conflict because of yours.


#28

The second message is caused by the first message, the game stops parsing the mod data correctly after it hits the laser special attack snag, which leads to missing items and debug messages. I’m not sure what’s been changed lately to break that portion, probably a further enhancement to custom special attacks. Deleteing the “LASER”, 1 portion from the specified entry might be a temporary hack that will at least allow the mod to load correctly, thought the solar bot won’t have a laser attack anymore.
I’ll get around to figuring it out eventually, but if you want to give it a shot, try copying the custom special attack from one of the other robots. It may be weeks more before I can sit down to work on cataclysm again, and I’ve got a list of my own mods to work on first before I get to updating other peoples stuff again :slight_smile:

If you should happen to get it working, feel free to post it here for everyone to enjoy, we’d all appreciate it. Cheers!


#29

So i took matters into my own hands and starting tinkering around to the best of my abilities ( to be precise i have none in that department ) and looked into what causes all the errors.
So of course, the first thing is the solar bot laser attack. This can (like stated by Malkeus) be fixed by switching the special attack out.
But after that, the murder bot is gonna cause trouble, and here the problems started. Here, the Turret ability is causing problems, like the laser did for the solar bot. I tried removing the turret which brought up more problems with the other two attacks the bot has, so i ended up removing the murder bot, which in the end fixed it.

This is by far not the best method of fixing it, but if anyone has problems with the mod this might fix it.

Let’s just hope Malkeus can fix it sometime, cause this is probably the worst way of doing it.


#30

I have not had a chance to personally test it but see post 5 here for an updated version of this mod. Posting in this thread to draw specific attention to it since I’m probably not the only person who’s been disappointed that this mod has been broken for quite some time. I figured that posting about it in this thread might draw attention to the posters update that might otherwise be missed by people who want the mod.


#31

For laserbot i just gave it the attack that the deployable sentry that requires light has with some tweaks, smokehack has smoker zombies smoke stream emit fields with a breath special attack, unholy murder bot has its attack switched out with “emit_fields”: [ “emit_smoke_stream” ],
“special_attacks”: [
[ “SHRIEK”, 20],
[ “BREATHE”, 3 ],
{
“type”: “gun”,
“cooldown”: 1,
“gun_type”: “laser_cannon”,
“fake_skills”: [ [ “gun”, 4 ], [ “rifle”, 8 ] ],
“range”: 18,
“ranges”: [ [ 0, 30, “DEFAULT” ] ],
“require_sunlight”: true
}
],
, and cleanerbot has its invalid flag switched to poison (only makes it poisonous to eat but is close flag to its invalid flag).


#32

Also just to inform anyone that uses the tweaked version that I might need to balance it more especially solarbot’s attack-range and damage.


#33

Ok nerfed range a bit for the solar bot to 15 from 18 and dropped its fake skills by 2. https://drive.google.com/file/d/0B2LKlCxhWTlWUTZoUnY3YnN2V3c/view?usp=sharing


#34

For some reason i thought the mod was a play as a robot thing which would be a cool thing though having robot minions sounds cool too :stuck_out_tongue:


#35

I use last experimental.
I can “Butcher” robots and pick them (weight a ton) and dissemble, also I can use some tools on them with 0% prob, success.

In few words: I m lost. Have mercy and give some instructions.


#36

You need the robots for fun book and most robots require the wreck item so if you want a bot do not disassemble them.


#38

I FIGURED IT OUT, I think. I got it to work on the latest experimental build as of today by moving things around in the places it said there is a problem. Something with arrays causes an issue with special attacks, so changing every line that does not work from
“special_attacks”: [[“SMG”, 4]],
to
“special_attacks”: {“SMG”: 4},
will make it stop giving errors, I have not tested if the bots work in game but it looks ok to me, but then again I don’t know how to code at all.

also if there is an array of items then changing it to this format made it stop giving errors: {“RIFLE_TUR”: 5, “SMOKECLOUD”: 4 , “SHRIEK”: 20}


#39

I can’t seem to get it working. The original error message was about “special_attacks”: [[“SMG”, 2]] in the jrr_monster_override.json file, rather than [[“SMG”, 4]]. I tried changing it to “special_attacks”: {“SMG”: 2} and it didn’t work. Tried with {“SMG”: 4} and got the same result. Here’s the json file pic. Any ideas?


#40

Having the same issue. Changing the brackets as described above hasn’t helped.


#41

Oh I see, my error was different all together so what I did won’t help yours. I had an invalid special attack error. No ideas how to fix them sorry.