Impossible to begin a new construction (vehicle) 0.C-19619-g4dbf3e2 / 5879


i tried to begin a new vehicle, i had a steel frame. In my construction menu, i had “begin new construction” in white.
So let’s go… Then i got an error message (see bellow), the pop-up to name the construction and … nothing…
my frame disappear and no construction left. i tried with light and wood frame for the same result whatever it was at the ground near me or in my inventory.

error message:

DEBUG : attempted a recipe with no available components !
FUNCTION: comp_selection<item.comp> player: :select_item_component(const std::vector<item_comp>&, int, inventory&, bool)
FILE: src/crafting.cpp
LINE: 825

anyone know what to modify to resolve this bug?

thanks for reading and futur answer :slight_smile:

It’s a known bug, currently you need to have two frames to begin vehicle construction. You only need two frames for the first tile of the vehicle, expanding it only requires one frame per tile after.

Do you have Blazemod installed when you attempt vehicle construction?

try to use wood-frame for BEGIN of build your car.
first use wood frame
after connect to wood-auto your steel frames and all be ok.

at least about six months ago, when this error popped up, I likewise bypassed this problem. just beginning to build a car starting with a wooden frame and then attaches to the steel and it was all ok. but when I started to build cars with a steel frame - have mepnya and cars did not appear and the frame disappears. Such are the cases. try. It can be a wooden frame remains “untouchable” for the error and the game will create you a car.

yes i not fix this problem but i found some-about bypass and it been ok for me.

after that - i mean you GET your car of one wood-frame, and after connecting to this errr (let’s name it CREATURE) your steel frame - simply remOve your wood frame. voila! your car is will be maked from steel

Hi everybody,

thanks a lot for your answers and your tips !

@BorkBorkGoesTheCode : yes, i’m using blazemod.

@proxiehunter/ vivat : thanks for the tip, i was close to stop CDDA for a while ! So … THANK YOU ! I can continue to cheerfully survive :slight_smile:

I found the problem: Blazemod has a custom vehicle construction entry. It is supposed to add blob frames as optional vehicle construction items, but it adds a second frame to vehicle construction as well. There are two possible fixes for this; I’ll post them after testing.

This has been discussed before: