Horse went 'Poof'

I found a horsie for the first time in CDDA. Fed it some food to befriend it, gave it a saddle, and road it around for a few minutes.

Then I dismounted and it simply vanished from existence without any error presented or any relevant messages. No idea what became of it at all.

horses are kinda buggy for what i have seen on the forum. I think there has been some info about the horse dissapearing and then later appearing (this one just appearead again as magical as it went, so iirc there wasnt a solution at all), and the second was weird bug of the time dilatation horse after dismounting, maybe it was the second a it just went away super fast. have you tried changing z levels and see if it reload back to existence?. (and have you have z levels turned on?, maybe they went to another z elvel pretty fast)

Yeah I think I know whts causing this, but ive been dragging my feet on the fix.
I think it’s moves get saved up, and not used while its being ridden.
Then used all at once, when dismounting.

Eh well, I pulled my finger out , and fixed it, was easier than expected.

1 Like

Ah, so it was turning into super-warp horse when you dismount. Cute. :smiley:

Ah, ninja’d. I was gonna make a PR for this myself, as I fixed it in my repo while I was up late last night. :grin: