[GMC] Goats Mod Compilation V 0.1.8 now with GMC.exe

will only be released for F.0 (or the casing fix release) then ill continue with updating everything onces all this is done

allright, sorry for late replies… turns out Animatronics mod has “Bad Terrain” error that caused it to unloaded from the world.

minor error though, still fun to play.


Can you post the error image here?

tell me if its fixed with the update

I installed this via the directions, but when I run the game (via the launcher) I don’t see any new mods.

Hmm, ok, I think I fixed that problem (I just moved the folders into mods instead of just data), but now it seems like the “No” mods are conflicting with already installed, mods, even though I moved all of the already installed mods out of the mods folder, so it’s just the compilation mods there.

Oh wait-maybe it’s because I have all 3 folders installed?
Edit: Yup, that was it.

update? which one?
im currently using E-Stable Release

forgot to screenshot it but i remember the error says :
“loaded bad ter! bankrupt_pizzeria_north”
“loaded bad ter! bankrupt_pizzeria_east”
“loaded bad ter! bankrupt_pizzeria_south”

"yourCDDAdir\mods" put everything but mainline and no mods in here
"yourCDDAdir\data\mods" only place no mods and mainline mods in here as they overwrite everything if you want

alternitivly drop everything inside "yourCDDAdir\data\mods"

thought this was experimental thought i fixed it, E release has some bugs

EDIT: currently linting everything in E then ill fix the bugs and such post back when its done

there isnt a north east south bankrupt_pizzeria its just bankruptpizzeria and it spawns i will need more info to fix this maybe a save and debug.log if possible the crash.log

okie dokie~ will post the necessary info, right now im doing some testing on all the E-stable mods available because i found that some mod has like weird and funny items and description (shoggoth maid, most OP partner + weird one…)

i actually got this bug, it wasn’t bankruptpizzeria thought. if your game wont launch now I had to reinstall cdda for some reason, it came out of no where and isn’t mod related. since i actually got it with any mods installed.

I’m not a very fluent person when it comes to modding so bare with me please. I followed the guide as well as I could, but ended up getting a black screen on launch. So, to get around this I uninstalled everything, and reinstalled things folder by folder to see where the problem was. Turns out it was in “Unlesh_the_mods”, unfortunately that’s the largest folder, so instead I checked the logs, and saw “there is already a mod with ident WHALEYHAIR_UDP” at the bottom.

I remember this one specifically cause I was having trouble figuring out where to put the tileset folders, anyway the “Whaleys_New_Hair_mod” and “Whaley_Hair_and_Tattoo” folders share the same ident in the modinfo json. I don’t know if that is actually what was causing the black screen, but deleteing the former folder DID get rid of the black screen. If I wanted to keep both, I assume changing the ident on one of them would make it work? I just don’t know if that is ‘safe’ to do or not.

Edit: I should probably mention this was with the experimental build version.

Yes, that will fix it. If you didn’t use the mod before (and there’s no other mod dependending on it, which I doubt), it’s “save” to do.

Alright, thank you. :slight_smile:

Seems to be the same problem with Zets hair mod as well. What is it with these hair mods lol. I’m starting to think I shouldn’t have installed those tileset mod folders.

here’s were bugs get posted Post issues on the forums or Post issues on Github

Can you please share what’s the state of the Salvaged Robots and Jury-Rigged Robots? What should I download to play them without errors on the latest experimental?

It’s confusing there’s 2 Salvaged Robots mods: “Standalone” and “Civilian”. They throw a bunch of errors along with Modular Turrets and Advanced Technology as their dependencies.

Looking through the errors, it’s seems they have legacy formatting and/or flags. I’ve managed to fix the errors that forbid loading, but still get around 10-15 of non-critical ones.

Threads two years stale now, and looks like the actual github repo is about a year and a half stale. My guess is there is nothing you can download to play without errors on the latest experimental, its been abandoned. That’d be why its floating so many legacy issues. Core ones are probably the same, referencing things that don’t exist the same way now, if at all.