Error Message on Certain Scenario

I’m not sure what is causing it exactly but, every time I attempt to do a Robots start, the game complains that it cannot create a valid starting location.

At first, I assumed this to be an issue with the building mods or Z levels. So I copied my world and removed all the building mods and the Z level option and still encountered the error.

The game specifically said to report the issue somewhere, so, here I am wondering why it is not working.


Further context.
Female Drone Operator, Freeform Creation, Dead People Tileset.

Mod list:

  • “dda”,
  • “magiclysm”,
  • “aftershock”,
  • “ArmUpPAUtil”,
  • “ArmUpSurvEx”,
  • “arsenal_breach”,
  • “FIC_Weapons”,
  • “ew_pack”,
  • “makeshift”,
  • “More_Survival_Tools”,
  • “DinoMod”,
  • “modular_turrets”,
  • “Salvaged_Robots”,
  • “secronom”,
  • “alt_map_key”,
  • “Cata++”,
  • “fast_healing”,
  • “Mining_Mod”,
  • “MMA”,
  • “zets_hair_extensions”,
  • “cars_to_wrecks”,
  • “deoxymod”,
  • “blazemod”,
  • “Tanks”,
  • “necromancy”,
  • “Battery_Overhaul_Legacy_Mode”,
  • “no_npc_food”,
  • “manualbionicinstall”,
  • “no_filthy_clothing”,
  • “safeautodoc”,
  • “novitamins”,
  • “stats_through_kills”,
  • “StatsThroughSkills”

Quick Edit: That mod list is the one without the building mods, figured I should have mentioned that.

Sorry for posting twice about this but, I did some further testing on what is wrong.

Reduced my mod list all the way down to just the base game and the Scenario wasn’t there. A bit of mod swapping and copying of worlds and I figured out it comes from the Salvaged Robots Mod. The Mod requires Modular turrets to run as well.

Made another world copy and only put the base game and the two previously mentioned mods and I still encountered the same error. So this is probably a Mod issue and not a game issue itself.

Salvaged Robots adds a building called Robot Dispatch. But apparently it doesn’t REQUIRE it to spawn. You could try setting the minimum occurences to 1 and see if that fixes your problem. Relevant file is in data/mods/Salvaged_Robots/robot_additions/overmap_specials.json
“occurrences”: [ 0, 10 ],
“occurrences”: [ 1, 10 ],

You’ll need to start a new world to test it.
Let me know if that resolves the issue, I’m ever so slowly working on updating Salvaged Robots and Modular Turrets into a single mod.

1 Like

I’ve heard that those mods blacklist the control laptop for some reason, so I haven’t really taken them for a spin yet. Is this true? If so, I wonder why.

Modular Turrets does blacklist the control laptop. Deleting the file ‘blacklists.json’ resolves the issue, but you’ve got to do it every time you update. One of many reasons I want to overhaul them.

edit: Why? Probably an attempt at balance, with no control laptop it requires the player to emp every robot they want to recruit.

1 Like

Having got a control laptop for the first time a day or so ago I can confirm it is pretty OP. If nothing else it means you will never run out of ammo (5.56 NATO M855A1). I currently have 7366 of that variety. I think the Sig 522 is my favorite gun that uses it - although in practice the Hyper Driver and Heavy Rail Gun are even more OP if you have the time to make the ammo yourself.

I tested it five times on a 9695 experimental build, having swapped the number as you suggested. It did not work at first on my one world but, after making a new world altogether it worked every single attempt. The world I had made included only the two mods and the base Cdda. I am updating to latest experimental and will do another quick round of tests after ensuring the number is the same as before.

As far as I can tell though currently, your idea has worked so I marked it as the solution for the issue.

1 Like

Final tests:

9699 Experimental, changed the number as mentioned. Created a free form character with the only option chosen being the scenario itself. Tested it five more times, resetting the world after each quick load of the character, worked every time. So yeah, Malkeus’ fix is definitely how to solve the issue.

Edit: These final tests also included my full previously mentioned mod list that I put up above. Forgot to mention that.

1 Like