Drop item bug

When ever i try to drop an item it just crashes the game. why?

Would just like to pop in to say I have the same bug. I’m not sure what it’s about. If it starts happening for a given savegame it seems to be all the more likely to happen again. I just started saving often, which helps.

Other than that, you can always throw items instead of dropping them, that doesn’t crash but works poorly if you have a lot of items to drop.

Did you by any chance use an old save?

Not for me. This is the first time i play the game, running 0.7.1. It seems to sometimes be related to specific items, but I can’t quite explain it.

Right now I’m in a predicament, because I’m wearing a longbow, my inventory is full, and there’s a skeleton approaching so I’m trying to switch to my crowbar, which I can’t do without dropping the longbow, which crashes the game. I also tried throwing it this time with the same result, the game crashes (or well, not crashes, just freezes).

Here’s an image of what I see after I press enter on the drop-screen:

It loads the minimap but that’s as far as it will go. I’m getting this bug really frequently, too, but I haven’t had it in any of my other games (But I really don’t want to restart).

I’d say it crashes roughly half of the times I want to drop something. Maybe there’s a void item in my inventory somehow and when it re-arranges the keybindings upon dropping it goes haywire? I don’t know. It seems odd. I’ll mess around with it a bit once I survive this skeleton and see what I can find.

Hmm, unable to reproduce this…

Could you upload the save?

Next time I get the bug I’ll upload it at that point and give information about what items crashes!

Here we go. I tried dropping my rotten meat and it crashed the game (then again it crashed the game for all items I try to drop at this location, I think).

If I went inside to drop it, however, there was no crash.

Not sure what files are important but I’m guessing you need the entire save folder, which is in a .rar file here:


Edit: Messing around a bit more it kinda seems like the game crashes whenever I try dropping something while a creature is in view. Which is why it doesn’t crash if I’m inside. No mobs, no crash. Odd.

Edit edit: I left the game running for around 15 minutes now and eventually the game does load, however it is very very very slow. For example, if I click a button to move the character, it takes 5 seconds before he moves.

Edit edit edit: I picked the item back up and the lag was gone.

Interesting, can you post a screenshot of your autopickup rules list, or just copy/paste the text from it?
That definitely has the potential to cause issues if something isn’t working right.

Actually i think i got this some days ago testing some other bug.

All I did was drop a shittonn of items at one tile, which caused draw_ter() (if I remember correctly) to use minutes per turn, until I picked up the items.

oh and no auto_pickup rules

I’ve been suspecting that auto pickup is related to this. I initially posted a post saying turning off auto pickup fixed it (since the only thing that’s changed between this game and my previous games was that I turned on auto pick up for this one, considering it’s so useful for picking up arrows).

I turned it off and it stopped crashing right then and there but ended up crashing later.

My auto pickup is working weird either way though, it’s picking up stuff that (in game) is not marked to be autopickup’ed. In fact, I just checked my auto pickup folder and there’s no rules in there. In game there’s a single rule, which is to pick up bikini tank tops that fit (which is kinda funny).

It still picks up almost any small items, though. Lighters, dust masks, bikini tank tops…

Edit: Picking up all light items is in the options though, I missed that one. Trying to turn that off and see if it changes anything.

Messed around with this some more, it doesn’t seem to be related to auto pickup. It’s crashing with it both on and off, even after clearing the rules, so I don’t think that’s the problem.

It definitely seems to be related to vision, though. Just now my game crashed while dropping an item inside, I then closed all the curtains and tried again, no crash. It’s almost like it has problems redrawing the world after something has been dropped but I have no idea how there can be a connection there.

:open_mouth: This is 0.7.1 not a nightly yea?

nightly yes.

Gonna post another small update. Changed the lighting to circular, and so far, no crashes.

Not sure if it’s just dumb luck but I’ll check in again if I should crash once more.

Edit: Played for a couple of hours now with no crashes. Definitely seems to be a lighting bug, but I have no idea why it’s related to the inventory. I actually prefer the whole circular lighting thing, though, so it all works out.