Don't try using the color template included in the game's own git repo, apparently

…so in my quest to push all the buttons, I checked out the colors menu, and out of curiosity I tried loading up the template included with the game, no_bright_background.json. That was a mistake, because since, attempting to start the game sends this error message:

 DEBUG    : Error: data/mods//dda/../../json/monsters.json: line 15:13: invalid color name

    "material": [ "flesh" ],
    "symbol": "X",
    "aggression": 100,
    "morale": 100,

 FUNCTION : bool main_menu::opening_screen()
 FILE     : src/main_menu.cpp
 LINE     : 534

From what I’ve found on this forum apparently some colors have been renamed, causing this error with certain mods, but it’s unfortunate that it’s a bug with a file in the official repo. Beyond that I have no idea how to just go back to the defaults (I get the impression I’ll just have to manually replace the template with the default colors?)

Does it do anything to gameplay or is it just giving errors? I get errors in my game as well about zombies trying to spawn over each other and ammo not fitting magazines when blockades form(does nothing tho).

No, I actually can’t start / load a game. The error occurs the moment I try and sends me back to the menu. I fixed it for now by just re-naming custom_colors.json, thankfully. I opened an issue on github to let them know.

Good to know. Thanks mate.