Chromebook Ubuntu Installation

I’ve both never used any form of Linux and spent a good couple of hours trying to solve this on my own; I’m hoping this hasn’t been solved elsewhere on this forum. Given my inexperience, I’d rather not accidentally leave anything out, so this might get SLIGHTLY weirdly structured.

Firstly: I’ve heard that if I use the stable versions, I should not need to do anything complicated on the level of compiling (a process which I understand poorly, at best). As far as I have been able to ascertain, typing “./cataclysm” should run the game, so long as I am within the directory that holds “data” “lang” “lua” and “cataclysm-launcher”.

When I do so, however, I get this error

I’m not sure what to download, especially given that I still don’t even really know what “libncursesw” IS.

I would guess you’re trying to run the terminal variant of cataclysm, and not the tiles variant.

First important thing is to make sure you’re not on an ARM-based chromebook, because arm-based ubuntu has difficulty with i386 and x86_64 processes and their libraries.

I’m not sure if cataclysm has an ARM variant, or if ubuntu has an emulation layer for arm, so you might have issues.

Once you do that, you need to verify that you have the libraries required to run this program. The jenkins builds are all 32 bit, so you might need to compile yourself if you’re running the 64bit version of ubuntu (default for chrubuntu). Normally I’d recommend adding multiarch with dpkg --add-architecture i386 instead of compiling, but I’ve found libsdl2mixer breaks a lot of things if you try to install the i386 libraries for it.

typing into a console “sudo uname --m” will notify you of your distribution type. i686 is the more recent moniker for a 32bit system (was i386. They’re basically the same thing), x86_64 is the moniker for 64bit, armhf for arm, etc.

If you’re running 32bit, skip everything below down to “Install Dependencies”

If you’re running the 64bit version, then you should probably compile it. Compiling is pretty straight forward, but if you really really really don’t want to then you can try skipping down to ‘install dependencies’ below and trying that first, and seeing if cataclysm will run despite using 64bit libraries.

This is a pretty straightforward guide to get yourself a working git pull and to install:

All of the dev packages have their base libraries included as a prerequisite.

You can compile the normal ncurses variant by leaving out TILES=1

It also shouldn’t hurt to add NATIVE=linux64 , even though it should be automatic.

You also might want to add LOCALIZE=0 , because ubuntu doesn’t come default with the localization libraries required for building that and I forgot what the package was called off the top of my head. (also those instructions don’t go over installing it anyways)

You’d end up with “make NATIVE=linux64 LOCALIZE=0 TILES=1” or whatever

Capitalization is actually pretty important to unix-based systems, so yes those words in capital letters aren’t typos.

\ Install Dependencies

You’ll want to satisfy dependencies to run this program.

This should satisfy the running dependencies (but not compiling, which you shouldn’t need if you’re just running the jenkins builds)

“sudo apt-get update”

and then

“sudo apt-get install ncurses-base libncurses5 libncursesw5 libsdl2-2.0-0 libsdl2-image-2.0-0 libsdl2-mixer-2.0-0 lua5.1”

Either way, after all that you should be able to run cataclysm via ./cataclysm-launcher

Also, if you’re running chrubuntu, the default user password for sudo is ‘user’. If you installed it yourself through seabios though then it’s whatever you set it to.

For crouton, I forgot, but I think it mentions it or has you set it in the install instructions.

Unrelated to getting this all running; just some tips for Ubuntu:

you can also install aptitude by doing “sudo apt-get install aptitude”. This is basically a more featured version of apt-get.
With aptitude, you can do things like “sudo aptitude search lua5.1” and it will list everything on your repositories that are available that either contain that string in their filename or summary. You can then type "sudo apt-get install " to get that file from your repositories and automatically install it. This is useful for when you’re missing dependencies, but if aptitude doesn’t find anything then you’ll either need to do more advanced stuff with dpkg or get the apt-file program to do a more in-depth search. If that doesn’t work, you might need to find more repositories like the webupd8 team’s PPA or the ubuntuX, who carry stuff that’s not on the default ubunbu repositories or just isn’t as up to date.

And now I’m into a different issue that I was having before.

I’m using the “Linux SDL/TILES” download from the cataclysmdda main page, and I’ve installed crouton and everything listed on the wikipage down 'til it tells me to type “make,” which I also had to install (sudo apt-get install make). I’ve gone through two or three iterations of “make” and “make clean” in my Cataclysm-DDA folder, and every time I tell it to make, it spits out at the bottom:

“g++: error: unrecognized option ‘–std=c++11’”

Also, this is NOT an ARM chromebook, it’s an Acer C720, so that isn’t the issue. And it runs the 64bit.

it means the g++ you have does not support c++11, i think.

do a: “g++ --version” to see your g++ version

using g++ --version spits out 4.6.3, so I installed something called an ubuntu toolchain which helped me install g+±4.8, supposedly.

sudo add-apt-repository ppa:ubuntu-toolchain-r/test sudo apt-get update sudo apt-get install g++-4.8

g+±4.8 didn’t say I had any problems, but the make command still has the same problem and g++ --version still tells me that I have 4.6.3, so I’m unsure exactly how that even makes sense.

far as i understand, you have now both the old and new g++ installed, but the binaries are in different places.
The old binary is still in your $PATH. Maybe this is so b/c g++ is really a part of gcc? so if you have not upgraded all of gcc it still acesses the old binary?
i say, delete the new g++, your gcc, and install via sudo apt-get the latest gcc.
if it does not install g++, install this too separately.
finally you could also upgrade make while you are at it.

in my pc i have:

make: version 4.0
g++: version 4.9.1
gcc: version 4.9.1

…but since i have arch linux, i expect these versions to not be available in the ubuntu repos… the latests ones in their repos should be fine though

Following this site ( and it’s instructions solved the problem. I didn’t realize initially that the install command wasn’t actually making anything available for use, just getting it there. Additionally, I didn’t realize that when it says “usr” it actually MEANS “usr”, not whatever my username is.

As far as I can tell, it is now working pretty much perfectly. As a final question: is it possible run it from, say, the desktop or somewhere a leeeetle closer than “/home/kailrik/documents/cddasdl-current/cataclysmdda-0.A/Cataclysm-DDA”?

Either way, much appreciated!

One way is to add the cataclysm folder to your $PATH
This will enable you to just run cataclysm-launcher from every open terminal to start catadda

to do that, you have to enter this into a terminal

but this will only work as long as you do not logout.
to make it permanent, you need to add this line a script that runs every time at startup.

if you use bash shell, there should be a .bashrc file in the /home/kailrik directory
(its a hidden file, so ctrl+h to see all files, or edit it from terminal)
add the line to that file, restart and it should work.

if not, try to google about addind a new $PATH in ubuntu
there are more than one ways to do it, and some depend on your DE

i personally use the .xinit file (like .bashrc, it resides into your home folder) to add a folder for my custom scripts, meaning that my command gets executed when the X server starts up.

that syntax seems equivalent to the one i posted above (i tested)
if you do this, make sure that the line is ABOVE the “exec startyourDE” line (mine reads “exec startxfce4” as i use xfce)

PS. there are other ways to do achieve the same thing. like adding an entry to your menu. or placing an executable bash script at your desktop, that when run, it executes the following command (it may need to be run inside a terminal, idk ./home/kailrik/documents/cddasdl-current/cataclysmdda-0.A/Cataclysm-DDA/cataclysm-launcher