Noob of Linux need an Retard Guide for Compiling

Title. Even tried to read the guides for that, maybe because my language issues / no knowledge about Linux, I can´t understand at all how to compile a graphical version of the game.

Maybe a step by step guide somewhere, please? There is a error with some libraries that don´t let me run the tiles version and I installed and tried several guides for installing the libraries and never worked at all.

distro- Linux Mint

Well first you want git, to get it you just open up a console and do:

This is also how basically everything on Linux is installed including the libraries you’ll need.

Then you want to clone from the git onto your computer.
To do this you’ll want to first use the command line to navigate to where you want the working project to be, then do:

Next you’ll want to install all of the libraries, I suggest you look at this:

Keep in mind you’ll also want the dev versions of these libraries, for example instead of just sdl2_mixer or libsdl2, you might also need sdl2_mixer-dev or libsdl2-dev.
I don’t remember exactly which ones you need, but they should be listed on the github.

Once you’ve done that, you’ll want to try to compile it, so navigate to the Cataclysm-DDA folder with the Makefile in it and try something like:

At this point you’ll probably get an error about some library you missed, so just run an apt-get at whatever the error was about.
Remember to try appending “-dev” on the end of it if it doesn’t fix itself with a simple attempt.

You can compile with a bunch of different options, for reference I think my normal compile command is something like:

i’d add that it should be


… at least in my distro…

Package SDL2_image was not found in the pkg-config search path.
Perhaps you should add the directory containing SDL2_image.pc' to the PKG_CONFIG_PATH environment variable No package 'SDL2_image' found Package SDL2_ttf was not found in the pkg-config search path. Perhaps you should add the directory containingSDL2_ttf.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘SDL2_ttf’ found
/bin/sh: 1: astyle: not found
Cannot run an astyle check, your system either does not have astyle, or it is too old.
g++ -DRELEASE -DGIT_VERSION -DTILES -DLOCALIZE -ffast-math -Os -Wall -Wextra -fsigned-char -Werror -std=c++11 -MMD -D_REENTRANT -I/usr/include/SDL2 -DSDL_SOUND -I/usr/include/lua5.3 -DLUA -I/usr/include/SDL2 -D_REENTRANT -c src/game.cpp -o obj/tiles/game.o
In file included from src/game.cpp:110:0:
src/cata_tiles.h:6:21: fatal error: SDL_ttf.h: No such file or directory
compilation terminated.
Makefile:687: recipe for target ‘obj/tiles/game.o’ failed
make: *** [obj/tiles/game.o] Error 1

Anything of this makes no sense to me, I installed the dependencies that says the compile file. Or dunno, nothing it´s really clear to me.

Did you install dependencies with “-dev” suffix?
You most likely only got the user libs and not the dev ones. Dev ones are necessary to compile anything.
Also astyle

What do you need the compiled version for? If just for testing PRs, console version would be enough. If for playing, you could just get the binaries from
Unless you need to test PRs that change tiles or sound related code, that is.

Will this work on Raspberry Pi 2 too?