Cataclysm++ Mod

I’m getting an error that causes all the super soldiers to be unable to ever shoot with their weapons. Depending on how close or far away the player is, they will either attempt to fire (and waste turns since firing doesn’t work for them) or engage the player in melee.
Seems like a very mod-breaking error to me so I’m wondering why nobody else has reported it yet??

This made me think the error was only on my end, so I tried downloading an older experimental version than what I use, and the same error appeared… so yeah, what the hell.
Here’s the copy of the debug message:

DEBUG : Tried to set invalid ammo of placeholder ammunitions for zombie super soldier rifle+3

FUNCTION : item& item::ammo_set(const itype_id&, int)
FILE : src/item.cpp
LINE : 411

I also looked at the mods’ files and the super soldiers all seem to use “_monster” variants of playable weapons added by the mod. Unlike the playable weapons, which use batteries as ammo, these variants are set in each individual monster’s data to use an ammo type called “generic_no_ammo”.

I looked at the base game’s ammo.json file and this “generic_no_ammo” does appear there, and its “ammo_type” is “NULL”, whatever that means.

I then made a search for “generic_no_ammo” in the forums and the oldest result seemed to show an example of how to use this ammo type to have, well… infinite ammo on a weapon. So I’m guessing that’s the modder’s intention but something went wrong along the way.

Is this mod dead or there is hope for an update?

Why do you think it is dead?

It was last updated several days ago https://github.com/Noctifer-de-Mortem/nocts_cata_mod

1 Like

my bad, I have checked the statistics on github - it is not dead, i`ts rather slow pacing .
Though the mod is very good and has a potential. I hope one day to see it in a stable version

is the error caused by monster flag refactor fixed yet?

2 Likes

Does anyone know if this line will be fixed it constantly happens.
DEBUG : Error: data/mods//nocts_cata_mod-master/Monsters/c_monsters.json: line 40:7: invalid monster flag: “REGENERATES_10”

"flags": [
  "SEES",
  "
  ^
   REGENERATES_10",
  "HEARS",
  "SMELLS",

FUNCTION : bool main_menu::new_character_tab()
FILE : src/main_menu.cpp
LINE : 878

Update the mod by downloading the fresh one from the github!
It was fixed :wink:

“Supper” soldier, love it, what’s for afters :smiley:

Wait what, what do you mean with deleted ?

wont let me play at all. it said there was trouble with the survivor spawn and now it doesnt tell me anything it just doesnt load lol

edit: DEBUG : Error: data/mods//nocts_cata_mod-master/Char_creation/c_start_locations.json: line 3:30: must specify either ‘abstract’ or ‘id’

[
{
“type”: “start_location”,
^
“ident”: “Survivor_Holdout_l”,
“//”: “starts in Survivor Holdout. Not in use currently.”,
“name”: “Survivor Holdout”,

FUNCTION : bool main_menu::new_character_tab()
FILE : src/main_menu.cpp
LINE : 906

This archive of mods maintained by Malkeus for personal use contains a version of Cata++ that works for me on the 10551 experimental with no issue.

Alternatively, that particular issue is arising because the game is looking for “id”, but can’t find it. If you want to fix it, all you have to do is go to the c_start_locations.json file, open it as a text file, find “ident”, and erase the last three letters so it says “id” instead, then save it.

im having further difficulty getting a game started after editing the .json so i’ll give the download a try, thanks :slight_smile:

I seem to be having the same (or almost the same) problem as the guy above - Trying to play 0.E version and Cataclysm++ gives me game breaking error -

DEBUG : Error: data/mods//nocts_cata_mod/Char_creation/c_start_locations.json: line 3:30: must specify either id or abstract

[
{
“type”: “start_location”,
^
“id”: “surv_camp_l”,
“name”: “Survivor Camp Site”,
“terrain”: [ “surv_camp” ]

FUNCTION : bool main_menu::new_character_tab()
FILE : src/main_menu.cpp
LINE : 781

Tried downloading zip folder linked above, but im still having this problem. Any help? Cant figure out if i can download previous versions of the mod from github

Weird. I get a lot of errors on the latest experimental but that’s not one of them; Try this:

  1. Go to data\mods\nocts_cata_mod\Char_creation\
  2. Open start_locations.json
  3. Go to “id”: “surv_camp_l”
  4. Add sloc_ to the front of “surv_camp_l”. Make sure it’s inside the quotations and that the underscore is added. It should read “id”: “sloc_surv_camp_l” when you’re done.
  5. Continue through the file, doing the same for every line labelled “id”
  6. Save the file

I can’t guarantee it’ll fix it, though.

I wasnt playing on experimental. I was trying to play stable 0.E

Anyway, someone on reddit shared a link to github where i could download an old version of the mod Github link

Im not great with github, so i couldnt find it on my own

Cannot load a save or start a new one. Just gives me this error before booting me back to the main menu

DEBUG : Error: data/mods//nocts_cata_mod-master/Terrain/Npc/c_classes.json: line 25:10: duplicate entry in json object

"weapon_override": "EMPTY_GROUP",
"traits": [ { "group": "Appearance_demographics" }, { "group": "NPC_starting_traits" }, { "group": "BG_survival_story_RURAL" } ],
"//":
     ^
      "Uses the CBMs available to bionic prepper profession that count as NPC-usable, with a smattering of NPC-usable civilian, industrial, and misc bionics to add variety.",
"bionics": [
  { "id": "bio_metabolics", "chance": 75 },

FUNCTION : bool main_menu::load_character_tab(bool)
FILE : src/main_menu.cpp
LINE : 1188

Check out GoatGod’s compilation. Make sure you get the E Release and not the experimental.

edit: I’m dumb, I misread your post and completely overlooked the link. Oh well…try out GoatGod’s compilation anyway, it’s made just for 0.E Stable :slight_smile:

1 Like

Get the latest version of the mod, this has been fixed already.

2 Likes

Do you know where i can get it, i have the same problem

For what version?

For 0.E and 0.E-1 Stable: https://github.com/Noctifer-de-Mortem/nocts_cata_mod/archive/0.E.zip

For Latest Experimental: https://github.com/Noctifer-de-Mortem/nocts_cata_mod/archive/master.zip

The release for Experimental is updated periodically, especially if there are new functionalities added.

1 Like