Cannot shoot to a turret outside my field of view [SOLVED: it works with immediate aiming mode]

Version 11378 (a week ago)

I can shoot the AR-15 outside the lab, without light (very dark) even if I select as a target a tile that is outside my field of view.
But when I try to shoot (using f, a, c or p) the turret inside the lab it just keeps aiming; first the Current Aim: Moves to fire goes down to 69, then the Careful Delay goes down to 76 and then… just nothing. It doesn’t shoot.
Screenshot attached.

Am I missing something?

Nothing comes to mind for me. Got a save file?

1 Like

@Paul_Blay Damn, I sould have saved a backup at that point :(. Now I know better for the next time.

Now no matter what I try, it always work. I’ve tried replicating the situation using the debug menu on the same world and in a new one. It works fine.

Some interesting details: When it wasn’t working, I removed the main lab metal door and tried to shoot from outside the lab to inside. I didn’t work if the inside was dark (but it worked shooting to outside dark tiles). Finally I threw a flashlight inside the lab corridor and, with the turret lit, I could shoot it perfectly. I only tried from outside, but I would assume it worked also from inside. After that, the problem was fixed for everywhere and I could shoot inside the lab without light so… I’m not saying it’s a bug for sure, but it seems possible.

I remember seeing Vormithrax doing something similar (throwing a flashlight to lit the turret) but I’m not sure if he did it just to know where exactly it was or if he knew it sometimes fails if not lit up.

I think you can’t aim at random locations, so firing only works with the “no aim” firing mode, which means lighting the turret up ought to allow you to aim rather than spray bullets towards that tile.

That would be a reason to throw a flare at the target.

1 Like

@PALU Then why can’t I replicate it? O_o
After the working around described above, it always work, no matter what I try.

And what’s the no-aim firing mode?
I don’t see it on the list:

It happened again! But now I could make it work :D.
If I’m understanding it correctly, the problem was that I was aiming at a turret on a tile outside my field of view. It works if you aim at any other tile (e.g.: the empty tile behind the turret).

@Paul_Blay Here you have the save file. If you try to shoot at the specific tile shown on the image (it has a turret), it doesn’t work.

Not sure if this what @PALU talking about; I would say it’s the opposite of “you can’t aim at random locations”, what you can’t do is aim at a turret (I suppose any enemy (?)) outside the FOV, but you can aim at any other random tile. And if, with “no aim firing mode” you were referring to aiming to another tile… then you nailed it :).

Thanks for the help!

I’m not in a position to test it right now, but can you shoot the tile if you aim at it until you’ve got the steadiness you want and then shoot by pressing the f key?

1 Like

From the original post, this is the behavior:

Yes, I’ve read that, but that didn’t answer my question:

As in: Select the tile, press a/c/p until it has the necessary steadiness (equal or over your preference) and then press f (not pressing f immediately).
But given your answer to my question, you probably did that…

1 Like

Sorry, I didn’t think using a/c/p instead of f to aim could be any different than just pressing f. I just tried it on the savefile and I was wrong, the Current Aim: Moves to fire and Careful Delay values only go down with f, not with a/c/p.

1 Like

Okay, I got it to shoot. Here’s how.

  1. Load file.
  2. Press ‘f’ once
  3. Press ‘s’ to select firing mode.
  4. Note that default aiming mode is set to 3. Careful.
  5. Change it to 1. Immediate
  6. You can now fire with ‘f’ as normal.

I guess at some point you accidentally changed the default aiming mode.

1 Like

@Paul_Blay You’re right!

I guess at some point you accidentally changed the default aiming mode.

I changed it on purpose ^_^, I thought the diffference was quantitative (more or less time aiming), but the Immediate mode has a qualitative difference. It doesn’t aim at all. This also explains why when I was testing my (wrong) solution of aiming to the tile behind I was being killed almost always (if I didn’t killed the turret on the 1st shot). I was using a non-immediate aiming mode and wasting too many action points.
Also… (@PALU) “no aim firing mode” = “Immediate”… duh! I’m dumb, hehe.

It feels weird that, when shooting to a tile outside my field of view, the behavior depends on what there is on that tile. I mean, I cannot see it, how does it affect how I shoot? But this is just nitpicking… understanding how it works is what I needed. I’m a noob and not the one to say how it has to work.

Thanks a lot for the help! I learnt something new :).

1 Like

Yes, I meant the immediate mode, as you figured out.

I believe the logic is that you can’t improve you aim by aiming more carefully if you can’t see the target to aim at it. However, the UI would be more functional if it didn’t allow you to try to aim at something you can’t see by graying out the useless alternatives and inform the player that the default mode won’t be used (or a popup at that stage informing the player, and allow the player to disable it in the future) if it isn’t the immediate mode.


I still don’t understand why this doesn’t apply to empty tiles outside the FOV. It’s the reason I was so confused at the beginning.

Maybe you could do me a small favor? Look at

and confirm that I’m not imagining things. :stuck_out_tongue:

My guess is that it’s a bug and the aim check was implemented only for when there was a target, forgetting the normal case. That’s only a guess, though.

1 Like

@Paul_Bay Replicated and reported on the GitHub issue.

1 Like