Butchered Meat Chunks Share Weight and Volume of Corpse

I started butchering recently and I noticed a problem. The raw meat chunks all share the exact same weight and volume of the corpse resulting in an absurd amount of weight and volume being created by butchering. Thankfully fixable by cooking them but still a major bug.

Which version are you using?

Sorry I should have been more specific. It was the source I got using git. Latest version, I just pulled it today. To be precise it is
Compiled it on Linux.

This cant be good: “Squirrel corpse of chunk of meat”…

Will look into it, thanks for reporting.


My fault, sorry =[ Found a crash bug and fixed in https://github.com/CleverRaven/Cataclysm-DDA/issues/2527 which fixed it…and changed how the item class determined what a corpse is…aaand forgot that I linked meat to corpses using that variable >.>

1942rob fixed it https://github.com/CleverRaven/Cataclysm-DDA/pull/2543
And so did I https://github.com/CleverRaven/Cataclysm-DDA/pull/2544

Both are equally valid fixes; while 2544 retains the meat linking (crow meat is different from moose meat), it’s completely unimplemented in game so far ( unless you’re a carnivore or have bio_scent and examine the item )

Critter meat being different in-code would allow for it being usable to flavor the mutagens differently. Moose meat might go for cattle (large, shaggy animal, OK? I know it’s not a perfect fit), crow for birds, fish for fish, etc.

FWIW fish meat ought to be distinguishable, at least.


Yea that’s what it’s all about, also you can have buffalo burger vs cow burger, which might make a difference at some point.

The most basic part, having meat “remember” where it came from is in there, but then we kind of didn’t follow up and do anything with it. >_<