Bug when i am in the main menu

So, i just got the newest expiremental, and whenever i exit a menu in the main menu like options or create world, and it zooms my game out.

What do you mean by “zooms my game out”? Could you provide a screenshot?

I cant provide a screenshot, as i’m on android.
What i mean by"Zoom Out" is that my game changes resolution in the middle of play.


1 Like

Well, i got a picture!

Not sure if this helps but:

Should be probably resolved with https://github.com/CleverRaven/Cataclysm-DDA/pull/35623.

I’m not sure if this helps (I was going to open an issue on GitHub this afternoon, coincidentally) but I think I’m getting the same issue. This was after the most recent Android update, and reverting to an older CDDA build didn’t change the issue even though those builds were fine before.

I cannot change terminal resolution at all. It seems to try to update the terminal resolution after being in the menu, even if it hasn’t changed. I checked the options json file after closing the application, and it didn’t reflect the changes I made, and relaunching the application resets it to the resolution in the json file.

More miscellaneous info:

  1. I can go into the menu, and back out without changing anything and this will occur.

  2. I initially noticed this after an Android update and with a fully configured options file. I went to the options menu in the ESC menu in-game to re-enable autosave after I had loaded a game and this occurred. I uninstalled the app and reinstalled a previous version I was using and it was still occuring.

  3. I have not tried editing the options file manually to set the desired terminal resolution, though I thought to try it as a workaround.

I looked at the change you’re referencing, and I don’t know if it’s related or not (I haven’t looked at the code at all so I’d be more willing to trust you over my own hunches) but I figured that more information couldn’t hurt.

Please let me know if you would like any more information from me (Android specifics, etc)

Thank you!