AR-15 not leaving shells (solved)

My heavily modified AR-15 is not leaving behind expended shells. It’s using .223 Remington ammo in a drum magazine. I realize this may be part of some of the mods I use. If so, if someone knows which one please let me know and I’ll report it to the mod author instead.

Weapon Mods:

Also, to the best of my knowledge the description is totally wrong. :stuck_out_tongue: The AR15 is a civilianized version of the M16.

The brass catcher mod dumps the shells right into your inventory. Are you not getting shells in your inventory after the gun is fired?

Yes, I know it does. And no it’s not. Now I just went and modded a M4A1 and fired it using the same ammo. I fire it once and all of a sudden I have 12 shells in my inventory. They weren’t there before. I specifically checked.

PS: Any idea why a STANAG drum mag doesn’t work in an M4A1?

I specifically went to where I knew there were more zombies. Now with a M4A1 I’m shooting .223 Reminington ammo and no casings are showing… WEEEEEIRD! I still have 12 in my inventory.
Ok. I think I have some idea of what’s going on. It’s waiting till I unload the weapon to generate the shells.

Have you tried removing the magazine from the gun?

Yeah, that is what is generating the shells. Sorry if you didn’t see my updates.

editing your OP post lets you edit the topic, add a (solved) on the end so people know you no longer have a problem.