Am I doing the get software mission wrong?

I wasn’t sure if this should go in the bugs or in this catagory, but while i was playing i got a mission to Retrieve Software from a computer. i went over there with the USB drive, downloaded hackPRO from it and talked to Richie. However, after I had the USB with his software the option to give it to him for the mission went away. Is it because i brought him with me so it didn’t work? (I’m playing experimental BTW) i tried giving it to him, trading it to him, having him use and it didn’t work! What’s wrong?

In all likelihood the option to turn the mission in will be in the dialogue instead of something like giving them the Drive.
Use “M” to check mission status. It will give you the location of your current objective expressed in overmap (“m”) coordinates. At the indicated set of coordinates will be something you have to interact with to complete the current objective.

I’m afraid I have no direct experience with a mission for hacking software; I’ve only ever seen one for medical data. In that one I had to get to an indicated hospital, and interact with a terminal to download the data onto a flash drive I was given. Then I had to return to the NPC’s location and there was a dialogue option asking if the mission was done yet. It seems that there should be a Dialogue asking how the mission is going as soon as you try to talk (“C”) with the NPC. Giving it to him wouldn’t work. The only way the game will mark it as accomplished is if you use the dialogue option. If that went away, then I’m not sure what you can do.

I’m not sure what could be causing your problem, but are you sure the flash drive you have is the exact one given to you by the NPC? That might be important, and drives with HackPRO do spawn sometimes, so you might have the wrong one somehow.

 Seems like I did everything right, the dialogue simply disappeared. The guy only had one computer in his house and I only had the one flashdrive thingy from him, so how could i have done it wrong? I have a second Hackpro, but that was gotten later.

While I don’t know what’s causing the problem I can show you how to reset the mission through the master.gsav.
This doesn’t require that the game be open since it involves editing the data inside the world. In fact it requires that you close it so that the game can load the new data for the mission. Please be aware that I’m not actually a dev. I don’t know the technical details involved in this, but I have constructed a workaround that is sufficient for myself. Implementing it does require paying attention to what you’re doing. Please let me know if you want to try it.

 I'd like if you could tell me, doesn't mean I'll do it but if anyone else sees and has this problem it could be useful to them too. Just to mention, I did reload the game a couple of times to see if it worked. It didn't. Luckily Richie trusts me pretty well despite the fact I never completed his mission, after all I did give him a bunch of food and armor and stuff like that.