Accidentally my whole /home/ with Intel Crystal Well on Archlinux64, now especially when walking outside 4fpsmax


#1

I tried reinstalling libs, another version of cdda, no mods, setting up .drirc which disables vertical sync…

all to no avail. A benmark reveals no more than 3-5 fps when walking on an empty field with no critters in viewing range. Before it’s been working just fine.

I got hte idea it must mean a whole lot more work for the cpu because the fans start going up in the first 3-6 steps outside.

Anyone experienced this?


#2

Maybe related to this issue https://github.com/CleverRaven/Cataclysm-DDA/issues/26372


#3

confirm
and this!

is that a recent change or does it point towards something?

What I’m getting at is the lack of drawn boxes around the choices.


#4

How’s the situation on latest master?


#5

haven’t checked I got the tiles version eventually and that one runs very well. Will do though. I still believe it had something to do with the framebuffer, whose function I yet have to understand completely but I started trying to get all set up.

Just downloaded the newest curses build. Feeling very smooth so far. Only have I gotten two seg faults. Might be the mods.


#6

Just as an update:
Upgraded my game from 8050 to 8083, Windows Graphical edition. loaded up my savegame from 8050, where i already had some fun, even changed the weather to rain, just to see if any issues show up: Nothing at all. Game seems to run very smoothly, barely uses any CPU and not even 1gb of RAM. Keep in mind, I have a heavily modded game, with 49 mods of varying sizes and I’m using the MSX+ Dead People Edition Tileset, so those numbers could actually be lower, depending on Tileset and mod usage.


#7

since the two errors I think I adjusted some mapgen and now it’s running very smoothly. Thanks!


#8

Returning player, Now from Arch-linux aswell
experiencing the same issue, low FPS using either CLI and Tileset

Do you mind elaborating on the troubleshooting steps you’ve undertaken here? The thread seems remarkably blend.
I’ve been running the game from the port to aur repo, Is this issue fixed in 8083?


#9

relax this is not arch :o) we dont have seriously serious expectations of you.

it’s fixed. and i tried all you did I think


#10

Apologies for having neglected to update this thread;
having compiled the experimental solved pretty much all fps-related issues,
… as i was previously using 0.C from the user repository.

I’m still not sure if the problem was part of the 0.C release, pacman package from the repo, or something on my end. But that matters little. tho we should probably make sure 0.D gets a solid port to our distro when it comes out.