Z change during Look mode doesnt work

So, as the title says, I can not change the Z level when in look mode. I have tried changing the hotkeys, but none of it works.

Do you have 3D FOV on?

You didn’t specify a version, so I just guessed.
Tested this in build version 10766 and it works fine.

As @anothersimulacrum says, you have to set the Options->Debug->Experimental 3D field of vision to true to be able to look around other Z layers.
(And Options->Current World->Z-levels have to be set to true as well, as it’s per default).

gah, that fixed it. thanks guys.