Water supply glitched in Luxury RV for latest build?

Latest build and I suddenly can’t use the kitchen to fill my canteen with clean water. The water tank has plenty in it (43 litres of possible 60) but I get the message “There is not enough clean water left to siphon it.”

Is the water frozen? The water tank in a vehicle is affected by cold the same as your canteen or a can of soda. If that’s it, you can open the cooking crafts & make clean water. It’ll come out hot but drinkable & safe.

I can drink directly from it, so it’s not frozen. I just can’t pour it into my canteen (or other container). Has there been a change to siphon code recently or something? I’m pretty sure it should just have a tap :stuck_out_tongue:

I have this same issue. I thought I was going crazy, as I could’ve sworn it had worked before. One work around is to siphon it with a rubber hose for now.

Hmm, then it could be a bit of wonky code or something, which I’d be less than worthless in helping figure out. The only other possible solution I can think of is, is the actual vehicle part damaged and unusable? Maybe the faucet or the vehicle part with a faucet in it (like kitchen unit) is damaged to where it isn’t working and needs repaired/replaced?

In my case, it is an underground stationary “vehicle” I use for my base. Nothing is frozen or damaged, and I can drink from the sink just fine. But I receive the above referenced error when trying to “reload” by canteen or when selecting the “refill container” option from the sink itself. I am almost positive that both of these options worked perfectly fine previously.

@Scais I wish I had a rubber hose!

@Sediment The RV has been left parked the whole game so far. Too precious to risk, also too much junk in its trunk (keeps falling to the ground :wink:

I think you “unload” the sink instead of “reload” the canteen. Then it’ll ask you where you want to unload it into - ground, container, down your gullet.

Edit: That’s more for carried containers, so maybe that’s no help with attached vehicle stuff. Maybe it is the code. I’m out of ideas otherwise. Sorry :slightly_frowning_face:

Ah, I see what has happened. I think.

The ‘kitchen unit’ has its own storage volume, separate from a ‘vehicle tank’ at the same location. I guess that was changed recently? I’ll try backing up the save then removing the ‘vehicle tank’ to see what happens.

[EDIT] Well, that didn’t work. It just stopped you from being able to do anything with water at that location.

Kitchen unit has had it’s own storage for a while, I don’t think is related to that.

To clarify, you can’t examine the sink, then select “fill a container” and select the canteen?

Yes, exactly that. It tells me “There is not enough clean water left to siphon it.”

It might not fix it but have you tried adding water to it and see if that does anything?

I had tried that, and it didn’;t. Although I didn’t get it all the way up to 60L

I experienced the same thing with my deathmobile it seems that when my rainwater tank on my kitchen unit is full I can’t siphon clean water out of my other tanks. It might be because my faucet is attached to the kitchen unit and the rainwater tank is on the kitchen unit. What I noticed though is when I cooked and use some regular water I could then drink from a clean water

Can you attach a second faucet to the tank instead of using the kitchen unit?

No its an exterior 100L tank. But as i said i havent had a problem as long as my rain tank isnt full

It seems like a weird bug, consider reporting it here: https://github.com/CleverRaven/Cataclysm-DDA/issues