Vehicle and Crafting Bugs

So far I’ve found a few bugs:

Crafting may crash the game; it seems to happen when a component takes up 2 or more inventory slots (Such as 5 amplifier circuits in your inventory and one being held in your hand or via damage). But I’m not sure

Crafting or modding a vehicle will crash the game at the “Which item will you use” prompt if there are too many of the required component nearby. Such as attempting to add a frame with around 26-ish frames nearby.

Modding a vehicle may cause the screen to black out, hitting spacebar seems to revert it though.

The “Can’t remove vehicle part due to something being attached” code doesn’t seem to work correctly. It’s possible to have vehicles with “floating” parts.

Was the “floating part” vehicle a wreck that you found? From what I’ve experienced sometimes the game will generate wrecks/chassis that aren’t completely connected, despite the fact that the player cannot build anything that way. The problem can right now be fixed in-game by creating an attachment between the floating parts and the “base” part, at which point it will allow you to remove the floating parts properly.

No, it’s possible to remove parts such that the remaining parts are floating. Find a regular car, remove everything from both trunk squares, and now you’ve got 2 boards, rear wheels, and rear hatch connected only to the side doors. Normally you can’t connect anything to the side doors, and you can still remove the doors, leaving the back part of the car connected to nothing.

Specifically, what appears to be happening is that doors don’t count as “connecting parts” when adding parts, i.e. you can’t add something attached only to a door. But they count as connecting parts when removing parts, i.e. if something is connected to a door and a frame, it’s legal to remove the frame since it’s still connected to the door. But doors can always be removed since they’re not connecting parts, so parts of the car end up attached only to the rest of the floating part of the car and can never be removed until you reattach them with connecting parts.

Only bug I had gave me a pair (common) of frames, which was IMHO useful, not intended (!).

I found a vehicle related bug aswel.

I crafted this mobile home from a schoolbus. Put a bed in it and all. But my character won’t fall asleep on it at all. It confirms it’s a “comfortable place to sleep” but when you try to lie down and sleep, you get the “you try to sleep, but can’t…” messages. Doesn’t matter if you’re tired or not.

That’s not a vehicle bug, it’s not even really a bug at all unless your character absolutely will not sleep anywhere.

Are you even tired? Ever tried to sleep while being wide awake? It’s hard to achieve.

How is it not a vehicle bug?

My character sleeps just fine everywhere except in the vehicle mounted bed.

I can’t replicate and I don’t see why the vehicle bed would be any different.

I’d suggest providing the save so we can tinker with it.

I can confirm the screen blacking out when modifying a vehicle. In my case, it was because I was attacked by a jumping spider so I guess the screen spazzed out instead of telling me I was hurt. Hitting escape solved it for me.

I also noticed a couple of other things different from .4. When I use the welder to fix parts, it does not use up the battery charges at all. Does not make sense. Secondly, performing one fix action on one part of a vehicle seems to sap up my XP pool. I repaired one broken wheel on my semi-truck and one frame (red) piece and took up 560xp that was in my pool. It did level my mechanics skill appropriately. However, one would think you would have to exercise your mechanics skill more times for the same amount of xp to be distributed to your mechanics skill?

How is it not a vehicle bug?

My character sleeps just fine everywhere except in the vehicle mounted bed.[/quote]

This might actually be a bug. Beds have a bonus to sleepiness. Even a car seat has a bonus, equivalent to a makeshift bed or cot. But car beds don’t seem to. Even the ground has a +1 bonus (cot has +4, real bed has +5) but car beds don’t seem to. Car beds trigger the “comfortable place to sleep” message, but they don’t provide a bonus to sleepiness like other beds. They probably overlooked this when they added car beds.

void player::try_to_sleep(game *g) { int vpart = -1; vehicle *veh = g->m.veh_at (posx, posy, vpart); if (g->m.ter(posx, posy) == t_bed || g->m.ter(posx, posy) == t_makeshift_bed || g->m.tr_at(posx, posy) == tr_cot || g->m.tr_at(posx, posy) == tr_rollmat || (veh && veh->part_with_feature (vpart, vpf_seat) >= 0) || (veh && veh->part_with_feature (vpart, vpf_bed) >= 0)) g->add_msg("This is a comfortable place to sleep."); else if (g->m.ter(posx, posy) != t_floor) g->add_msg("It's %shard to get to sleep on this %s.", terlist[g->m.ter(posx, posy)].movecost <= 2 ? "a little " : "", terlist[g->m.ter(posx, posy)].name.c_str()); add_disease(DI_LYING_DOWN, 300, g); }

bool player::can_sleep(game *g)
int sleepy = 0;
if (has_addiction(ADD_SLEEP))
sleepy -= 3;
if (has_trait(PF_INSOMNIA))
sleepy -= 8;

int vpart = -1;
vehicle *veh = g->m.veh_at (posx, posy, vpart);
if ((veh && veh->part_with_feature (vpart, vpf_seat) >= 0) ||
g->m.ter(posx, posy) == t_makeshift_bed || g->m.tr_at(posx, posy) == tr_cot)
sleepy += 4;
else if (g->m.tr_at(posx, posy) == tr_rollmat)
sleepy += 3;
else if (g->m.ter(posx, posy) == t_bed)
sleepy += 5;
else if (g->m.ter(posx, posy) == t_floor)
sleepy += 1;
sleepy -= g->m.move_cost(posx, posy);
if (fatigue < 192)
sleepy -= int( (192 - fatigue) / 4);
sleepy += int((fatigue - 192) / 16);
sleepy += rng(-8, 8);
sleepy -= 2 * stim;
if (sleepy > 0)
return true;
return false;

[quote=“Austupaio, post:9, topic:1307”]I can’t replicate and I don’t see why the vehicle bed would be any different.

I’d suggest providing the save so we can tinker with it.[/quote]

Ok, here it is.

And no, being tired or very tired doesn’t help for me.

I found this happening somewhat rarely in 0.5 for vehicle fixed item holders, this one being a box as seen from vehicle overview.
After a pop up question that queries if one should pick up an item from the vehicle’s holder and drop held item(s) the discarded one doesn’t show up in the box, only to be found below the vehicle. Note that the holder isn’t full (other, misplacement bug) and the discarded item is the one checked for pickup, not the one already wielded.