Ubuntu: Trying to add Cataclysm as a Non-Steam game

I installed Cataclysm DDA on Ubuntu using apt, and it seemed to install fine. I’d like to add it to steam as a non-steam game, but when I pick out the executable at /usr/games/cataclysm-tiles and run the item in steam it seems to run and then imediately stops. It doesn’t even open. I tried making a .desktop file for CDDA (which works) but steam doesn’t like that either.

I’m a little stumped about what I’m doing wrong, and I couldn’t find any help online. I’m still pretty new to Linux, so I may not fully understand the ins-and-outs of executing applications.

  • What do I need to do to start CDDA through Steam on Ubuntu?


From experience and what you are describing I think you may need to add a compatibility layer in Steam. Right click on the game you added in Steam, then Compatibility tab, then choose a Proton, if it does not work try not another Proton. Pretty sure it will work this way.

But I am 0% expert so maybe it won’t work because I guess CDDA is not a standalone executable file working on its own so maybe it needs to be completely installed with all its files in the compability proton environnement.

1 Like

Thanks for your reply, @Worlder! :sparkles:

I gave forcing Proton-Experimental a try, but it didn’t work. I’m not clear on what the compatibility tools are meant to do, but I think they allow non-linux games to run in linux. That’s pretty handy, but Cataclysm works on its own on my laptop so I’m not sure what Proton might do to help. :thinking::grey_question:

I took a look at the Right-Click > Properties > Shortcut window and it says:

Target: “/usr/games/cataclysm-tiles”
Start In: /usr/games/

That seems right to me, but maybe I’m missing something. :person_shrugging:

1 Like

I did try and made it to work using the Windows version under my Linux environnement : I downloaded Cataclysm for Windows, extracted it in a folder, then added cataclysm-tiles.exe to the Steam library, then right click, properties, compatibility, force the use of blahblah, Proton 8.0-5 (other versions may probably do the trick too), and that’s it that worked.

Actually I just tried with the Linux version and that worked too : download it, extract it to a folder, add the cataclysm-tiles to the Steam library (may have to check “show all files” when looking for that file), then press Play and boom that works.

Maybe try with the version downloaded from the Cataclysm website, it looks like it’s the only thing you are doing different. If you want to use the apt version I guess you will need additional troubleshooting

1 Like