Trouble Compiling (Windows VS 2019)

I am currently attempting to build the game in order to apply a patch.

I have cloned the repo, installed Git and Vcpkg, and all of the packages.
But when I try to compile I get the following build errors, and cannot manage to solve them:

error : The Vcpkg manifest was enabled, but we couldn’t find a manifest file (vcpkg.json) in any directories above E:\Github\Cataclysm-DDA\msvc-full-features. Please add a manifest, disable manifests in your properties page, or pass /p:VcpkgEnableManifest=false.

(Following the instructions here still leaves the below issue + I feel like disabling the manifest is not the solution?)

E:\Github\Cataclysm-DDA\msvc-full-features\stdafx.h(80,16): fatal error C1083: Cannot open include file: ‘SDL2/SDL.h’: No such file or directory

I have tried locating the files to no avail, and I have tried changing some settings as recommended by the great internet, but nothing seems to be working.

I would greatly appreciate some help if anyone knows how to get this working.


1 Like

Something is wrong with vcpkg - I blame which possibly broke vcpkg for non-English Windows versions.

You can try using older vcpkg version (checkout older tag and run bootstrap to build it) or disable vcpkg manifest in cdda project properties and install dependencies manually (see