Problem with compiling (Windows)

I’m having a hard time compiling since it’s my first time and I wanted to know how to solve this problem and how to compile/build the game:

I’m currently using Microsoft Visual 2017 as well as a Windows 10 as my OS and I’ve been following the instructions on GitHub , I’ve downloaded dependencies , run the batch and moved the files into root folder , installed lua in C:/Windows/System32 as explained and what I don’t catch up to is when it says make a new project as usual like a C++ (Because I’ve never done one) so I just opened the root folder and it started working/running unitl this popped up:

Error CMake Error at C:\Users\Usuario\Desktop\Smthng\Cata DDA mod\Cataclysm-DDA\CMakeLists.txt:314 (MESSAGE): This project requires ncurses to be installed to be compiled in text only mode. Please install the ncurses development libraries, or try compiling with the -DTILES=1 for a graphical compilation. See INSTALL file for details and more info CataclysmDDA C:\Users\Usuario\Desktop\Smthng\Cata DDA mod\Cataclysm-DDA\CMakeLists.txt 314

Thanks for your time and attention! :smiley:

Try to open \msvc-full-features\Cataclysm.sln instead of the root folder.

I’ve just opened it and it popped up a little window that’s trying to make me update the toolset version to 141 , so I think I should tell it that I don’t want any kind of update for the toolset.
It’s also asking me for a SDK version of Windows , here I’ve got 3 options:

  • 10.0.17134.0
  • 8.1
  • Without update
    Which one should I choose in both ?

Okay, finally compiled in Visual Studio and it popped up a mesage telling me this:

1>Generando código…
1>LINK : warning LNK4098: la biblioteca predeterminada’MSVCRT’ entra en conflicto con otras bibliotecas; use la biblioteca /NODEFAULTLIB:biblioteca
1>Cataclysm.vcxproj -> C:\Users\Usuario\Desktop\Smthng\Cata DDA mod\Cataclysm-DDA\msvc-full-features\…\Cataclysm.exe
1>Cataclysm.vcxproj -> C:\Users\Usuario\Desktop\Smthng\Cata DDA mod\Cataclysm-DDA\msvc-full-features\…\Cataclysm.pdb (Full PDB)
1>Compilación del proyecto “Cataclysm.vcxproj” terminada.
========== Compilar: 1 correctos, 0 incorrectos, 0 actualizados, 0 omitidos ==========

Which I think is okay because it tells me that it created a .exe (that is what i want) and also a .pdb (Which I have no idea what it is, then when I started the Cataclysm.exe it popped a little window of an error telling me:

  • The execution code can’t continue because it didn’t find SDL2_image.dll. This problem can be solved reinstalling the program.

  • The execution code can’t continue because it didn’t find SDL2.dll. This problem can be solved reinstalling the program.

  • The execution code can’t continue because it didn’t find SDL2_ttf.dll. This problem can be solved reinstalling the program.

  • The execution code can’t continue because it didn’t find SDL2_mixer.dll. This problem can be solved reinstalling the program.

(I vaguely transalted it from my native language , sorry if the English it’s a little weird)

Thanks for your attention! :slight_smile:

There is link to .zip with necessary libraries somewhere… section Dependencies.

Ensure that x64 dlls from the .zip file are in the root folder along with compiled .exe file.

Thank you so much! I finally achieved it! Now I’m going to try and test with the Debug system what I added! :smiley:

Hi, I realize this thread is a bit old however I did have a few questions. I followed the for visual studio and I received a few errors I was hoping I could get some help with. I am new to development, just out of college and want to contribute in some way. Attached is a screenshot of the error list on my screen. As well, I am compiling in Visual Studio 2019 Community with all projects in the Cataclysm.sln targeted for Windows 10.0.17763.0 and the Platform toolset is Visual Studio 2015(v140). I also ran the copy_dll_to_bin script and placed the contents in the root folder. So far I am a bit stumped and any help would be awesome. Thanks!