Shouldn't I be able to disassemble this milspec searchlight?

My character has crawled up next to the searchlight and generator.

I can “plug the generator into the grid” but I don’t know what that would do.

My hope was that I could unplug it from the turrets and the searchlight.

I tried to disassemble the searchlight, but it won’t do so. Since some cops put the thing there I don’t think it should be difficult to break it down and take it.

I really hope there is a way to drag this generator back to my base.

How do I turn off the turrets and take them?

You could examine the generator to connect it to turn it into an appliance. The bots’ll just have to die.


So if I attach the generator to the grid in the middle of the road that actually makes it into something I can move?

Why is the generator there if the bots don’t need it?

I wonder if I can (G)rab some big objects and surround the turrets in order to neutralize them until they can be repurposed. That said, I have no idea how I would move something big all the way out there. Perhaps a forklift can do it.

Examining it after connecting it to a grid will also allow you to take it down into an item, to be put in a vehicle storage, you could try to carry it by wielding but I don’t think many could be able to do that without injury.

The bots I suspect actually need it in lore but code-wise are not implemented yet, since they’re not treated as appliances but as monsters.

Thank you. it wasn’t obvious because I had to attach it to the grid before the other options became available. After making it into an item I was hanging around that light after dark and as far as I could tell there was no spotlight and the turrets didn’t shoot me.

I also lured three zombies toward another set of turrets and watched them for a while while they attacked one of the turrets. Neither the zombies nor the turret were damaged after some time passed.

You can just deconstruct the generator (using the * / construction menu) and it will become an item that you can just use the \ key to drag along the floor instead of grab-dragging like furniture). That or inspecting them as someone suggested above.

As for the turrets and whatnots, they’re not furniture, they’re enemies and they need to die. You can destroy them, disassemble (butcher) them later and hope you learn how to rebuild them yourself if you want some of them as your own (assuming they have a recipe you can learn, like most of them do).

And yes, Zombies will attack them, but lower and most mid-tier level zombies won’t do anything to them due to their armour levels.

1 Like

I loaded the 800+lb generator into the cop car somehow. (I used the “/” screen.) Presumably it was deployed from there. Unfortunately, the engine failed because the car was overburdened. That’s silly because a generator of that size probably wouldn’t be that heavy, but if it was, it would be quite difficult to load, and if it was loaded the car should have had no problems hauling it around as that is similar to the weight of six people. Oh well. It’s all pretty cool anyway. My guess is that the turrets were impotent because they ran out of ammunition. I also read elsewhere that the tiles don’t show the spotlight. Is that true? I tried a few different tilesets and none of them showed a spotlight. Since zombies can bash through doors I imagine they could knock a turret of that size over.

For the car to struggle with it, I wonder if the Engine was very damaged.

I’ve never had that issue. The engine failing certainly has to do with it being damaged or you finally losing all battery/fuel (unless there is yet another thing I am forgetting?).

Do you have a screenshot of the vehicle?

It might have run out of gas. If that is the case, the message from the game is misleading.

Could’ve been the gas or your engine being trashed.

At that damage level it takes several tries for it to start up.
The message being “The [engine] fails to start-up” for something, is essentially that.

That particular V8 Engine works up until, iirc, 15t of weight? Perhaps a bit more.

1 Like