Sewing books causing error

Windows console (this version of graphical was just CTD whenever I tried to run it)
When trying to select some sewing books (For designers in my shopping cart, for beginners once in a library) is causing a debug message to come up:
DEBUG: Invalid input to string_format function!

I have managed to pick up and read some of these books (started with tailor prof, read designers no worries, put it in the cart and now cant get it out), it only seems to be certain ones that glitch

You shall not sew.

Are you sure you have enough rags or leather?
I can reinforce my books just fine, though can never make them fit.

[quote=“FrankyPlaysGames, post:3, topic:5361”]Are you sure you have enough rags or leather?
I can reinforce my books just fine, though can never make them fit.[/quote]

Jokes should be funny. 2/10. Apply yourself more.

And I can sew just fine, im at lvl 6 now, so apart for maybe the new electric themal gear, in theory id never actually need to read another sewing book. It would just be nice to be able to touch them without the universe having a little brainfart is all.

My joke was hilarious. I laughed.

What do you mean with select?

Pick up? Read? Examine?

It helps if you give us the specific steps you make to get the bug.

So, you have the book “I am to lazy to look up all the book names” you put it in a shopping cart, get it out and it gives a bug and does nothing?

Also, are you running a non english language version of windows?

I have this bug too and I would like to provide some insight into it (if this wasn’t already reported):

First off, had this bug while reading a fabrication book (DIY Compendium IIRC). Dropped it to go off hunting and when I tried to pick it up again I received the error the OP reported. Once I pushed space bar though everyone was working normally again, I could even start reading the book again. But each time I dropped it and picked it up again, same thing happened.

Next character had this error with the sewing book, Techniques for Designers, or something like that. I could at first check the book like normal, see the list of recipes I still didn’t learn and all that stuff. But then, I reached the max skill for that book (6 tailoring) and now every time I check the book, I get the pic related.

It seems that the bug is related to the list of recipes learnable from a book once you reach it’s maximum skill.

I’m having this error with the Handloader’s Helper on my current character. “Any” Handloader’s Helper or just that specific book is a good question, because that’s the only one I saw so far. Whenever the book’s name would appear on the screen normally, there is an error. "e"xamining a bookshelf to get it fails, because the error cancels the examining, but you can move it into your inventory with advanced inventory management.

Alright, I havent got the save anymore, but ill try and go into a bit more detail.
Im running english and on windows 7.

So I go into a library and there are 4 books on the shelf, I examine it and it get something like this:
a book a
b book b
c book c
d book d
Say book d is the one causing the problem (sewing for designers, just dont want to type it out over and over). I can scroll through a, b and c just like normal, pick them up etc. As soon as I scroll over book d though, I get the mentioned string error and it drops me back onto my normal wandering about screen.
Ok, so fuck that book then and keep adventuring. I find another copy of book d and pick it up no worries, no debug message, just like normal.
Put it in my shopping cart with piles of other assorted junk and keep rolling. A few days later I want to pull some stuff out of my cart. As I scroll through the list when the cursor goes over book d I get the debug again and am dumped out to walking about mode. Pageup/pagedown to jump entire screens will get me past it, it is only when the cursor is actually on book d I have the debug.

So ok, remove most of the stuff in the cart and dump it, then pickup everything in the cart with the ‘select all’ thing (, by memory). Pick it up no worries. Read it no worries, get my tailoring up to 6 no worries, all good, dump it in the cargospace with all the other books on my car.
Later I want to grab something out of that cargo space. Cant even open up its inventory, I get the debug message as soon as I try.
Play a little more, get bored and die in a fire.

Havent seen the issue in any other experimental since.

So has it been fixed in the most recent experimentals? I could not reproduce it.

(I did find a different bug btw: it might have been related to that. The input string function getting display information (the color tags) while it didn’t expect them).

Well, ive played fairly extensively with 2 experimentals since and havent seen it so id be willing to bet its fixed.

Great. Thanks for reporting then. It did put me on track of more bugs.