Reloading tailor kits fails

So, I find tailor kits, use up the charges so it is 000/400. I try to load it with thread and the thread is taken, but the charges don’t get added, and the kit still acts like it is empty, so it isnt an update issue on the kit’s part.

Anyone know of a good fix to this other than spawning more kits?

what version are you playing? I just found a tailor’s kit and it works just fine

build 10703

my mod order is: DDA, disable NPC needs, Aftershock, blaze industries, DDA Lua, lua traits, mining mod, Zetsukaza hair, Lua Items, and Lua Fun.

yes I think that some of those mods are conflicting because i’m playing vanilla except for disable npc needs and it works

I tried it again on vallina, and i have the same issue. a spawned tailor’s kit just eats the thread. After unloading the kit i got this message:

DEBUG : cannot determine reload cost as none is neither ammo or magazine

FUNCTION : int player::item_reload_cost(const item&, const item&, int) const
FILE : src/player.cpp
LINE : 2708

So it is not the mods causing a conflict.

i just tried unloading and loading it again and it works

try creating another world, spawning a tailor’s kit or other types of needles and try again…

I guess I am too used to more obvious “update game” buttons. I had set the biuld to the latest without actually updating the game. The kits now work both in vanilla and the mod list i gave. Thanks for the replies.