Problem wielding

Every time I wield an item in build 8535 I get an error that sometimes crashed the game.
I’ve tried with knives, guns, and all sorts of other things… Including some that shouldn’t be wielded
The backtrace is:
02:14:13.489 ERROR : (error message will follow backtrace)
Backtrace emission took 0 seconds.
src/visitable.cpp:30 [item* visitable::find_parent(const item&) [with T = Character]] Tried to find item parent using an object that doesn’t contain it
02:14:36.785 ERROR : src/character.cpp:838 [item Character::i_rem(const item*)] did not found item trench knife to remove it!

My mod list is:
“dda”, “dda-lua”, “no_npc_food”, “filthy_morale”, “novitamins”, “adv_gear”, “Tolerate_This”, “craftgp”, “FIC_Weapons”, “realguns”, “growable-pots”, “ew_pack”, “makeshift”, “Medieval_Stuff”, “More_Survival_Tools”, “nw_pack”, “modular_turrets”, “Salvaged_Robots”, “alt_map_key”, “Mining_Mod”, “mutant_npcs”, “national_guard_camp”, “BIGRIVER”, “more_locations”, “FujiStruct”, “oa_additional_buildings_mod”, “oa_early_game_mutations_mod”, “Urban_Development”, “boats”, “deoxymod”, “blazemod”, “Tanks”, “Arcana”, “necromancy”, “Arts’ Guns”, “more_classes_scenarios”, “RL_Classes”, “manualbionicinstall”, “safeautodoc”, “StatsThroughKills”, “StatsThroughSkills”, “dda-lua-fun”, “dda-lua-items”, “dda-lua-skills”, “dda-lua-traits”, “with_extra_mushrooms”, “add_ebook”, “antifunguskit”, “porawep”, “Anesthesia_Crafting”, “WildLiving”, “crazy_cataclysm”

Can anybody help me figure this out, or is it a problem with the base game?

My bad, working on a fix

1 Like

I’m also having this problem with 8531 (didn’t have it in 8514).

Oh, good to hear it is being worked on. Thanks, ifreund.

Looking forward to the fix, thanks for the info.

This is why I’m playing a 13 day old build or so right now. Best not to play the latest version. You’ll also find lots of vehicle game crashes while turning. Was totally unplayable. Risks of playing a constantly developing games I suppose.

Fixed in the latest build, thankfully. I was about to go through Cataclysm withdrawal.

Right? Thanks Ifreund for solving this issue.

1 Like

Nice :slightly_smiling_face:
I was getting the same error when wielding the H&K MP5 and the kitchen knife.