NPC Stuck in Guard mode

I have an NPC that’s been following me since i recruited him in the initial evac center, and i put him to guard outside a farm house i commandeered, well i wanted him to come with me on a raid and when i open dialog with him to come, i pull him out of guard mode and end chat, and he won’t follow, when i go to open a chat again he’s back in guard mode and won’t come out of it… is there a fix for this or a way i can debug him back to normal?

The easiest way I have found to deal with this, is to get them to follow you, and then choose the option of ‘I’m going to go my own way for a bit.’ followed by ‘Yes, I’m sure’ when you get the next prompt.


I WOULD ENCOURAGE YOU TO MAKE A BACKUP SAVE IF POSSIBLE, OR POTENTIALLY (Due to said issue, would allow the method of, seeing as the game itself derped…) DEBUG TO COMBAT SAID % ROLL WITH TRAITS/NPC OPINION, ETC.

I have had this issue myself, not just with NPC’s that follow me, but ESPECIALLY when dealing with NPC’s setup at player faction camps (the ones you can build with resources, and setup jobs, etc.). This, as far as I know, yields CONSISTENT results on fixing them. Method two is if you are okay with debugging as being ‘an exception’ since the NPC derped tf out…

Edit: Welcome to the CDDA community! Most (speaking from my own experience here.). of the people here are pretty friendly. And are QUITE informative and helpful with their responses. And… some, if not most (Y’all know who you are.) are rather willing to not only help you with your issue, but also go as far as to give a step by step method of how to deal with it, or even share screenshots, test it themselves, and provide OTHER methods to do so, if need be. Please enjoy your stay, Ser. If you ever have issues or questions, no matter how silly they may seem, never hesitate to ask. :slight_smile: It is better to ask and potentially be informed, than not at all, and proceeding to butt your head against the wall trying to figure it out.

1 Like

Kitty, thanks so much for the welcome and quick advice. This worked for me, my NPC is now behaving normally, HOWEVER, he had a broken limb which I had previously splinted and was on the fast track to healing, but now it’s stuck at 0% and saying “the bone is set and needs time to heal”… Previously it was above 50% or so, I tried debugging limb health to 100 but it won’t change, is there another way to fix this?

My only guess, if debugging it didn’t work, I would try at least bandaging it, or checking to see if it is possibly bleeding, take care of that, and then bandage. Bandaging will slowly help it heal, much like bandaging your own wounds. The higher the condition of the bandage (Outstanding, or Perfect, preferably when applied and then checking the bandaged area.) the better it’ll heal. And if anything, bandaging is also a great way to get First Aid XP. Which for early levels, is extremely helpful if one cannot find a First Aid book to level with. Medical Gauze and I think rags can work as well. (If the area is not a deep bite, but IS infected, making an antiseptic soaked rag’ll help not only deal with some of the infection, but’ll also heal it overtime. Which, does help, in a pinch.)

Outside of that, maybe debug them a few mutations? Preferably one that involves regen. If debug healing it outright didn’t work, anywho. Hemostatic powder’ll help with bleeding as well, if it is the case. Or telling them to sleep, if the debug regen stuff doesn’t do anything either. Might help it heal, dunno for sure. Past that, I’ve got nothing… that I can think of. Just make sure they have a sleeping bag to use (such as unrolling a rolled up one, which mind you, takes up SIGNIFICANTLY less volume when rolled up. Just activate it to unroll it, and I think place it, or give it to them if placing doesn’t work. Or… if you have some sort of bed, that’ll suffice, since you won’t have to hunt for a sleeping bag or a roll mat.

IK NPC stuff can be really… wonky and sometimes even gimmicky. If they are hungry/thirsty, ensuring they’ve been sated (as long as you have NPC needs Enabled, and not disabled via the DISABLE NPC NEEDS mod… since they can hardly take care of their own needs…) might help as well. Hell, give them some cough syrup (the one that will make you drowsy.) if you can. Couldn’t hurt…

What limb in particular, is broken? Ik it has to be an arm or leg, as if your torso or head hits 0, you just die… same applies to NPC’s. So, maybe I can test something when I get home to see if I figure out another method or work around.

As always, I recommend a backup save, in case something happens… or the save itself does something stupid. Never hurts to have that extra ‘insurance’ policy for dealing with things that have derped themselves to Hell. And like I mentioned earlier… NPC’s (and the AI for them, amongst other things involving them) can be QUITE a fustercluck, for seemingly no reason. For example, I’ve had an NPC that was following me, and had full trust, highly balued, wasn’t at all afraid or hostile towards me by even a little, suddenly outright flee from me on loading up the save from where I left off. Then it’s either debug them, or try to literally fix their ‘bugged’ behavior through talking to them, if you can.)

did your charecter die and you start a new character when you returned to base? I’ve noticed NPCs can get “stuck” that way if you’re playing a different charecters

Not exactly, lol. Least, not on the same world. Mine occurred in two separate instances. One of them I had played on a DIFFERENT CHARACTER ON AN ENTIRELY DIFFERENT WORLD. (I use a world to test debugging and certain mechanics, and even testing ideas I come up with. But, I make sure to turn all the debugging stuff OFF beforehand. I met a WORLD SPAWN NPC (As in it wasn’t debug spawned in, it was a naturally generated dynamic npc.) that I then did their quest for (needed an inhaler.) real quick, and then had them recruited to set up a base camp in an area. (This was so I could also test something else that had happened on another world, with Faction camps. Needed to build one, though.).

After I had the camp setup (the little bulletin board), I then had them set to GUARD the location (I DID NOT ASSIGN THEM TO THE CAMP, NOR WERE THEY LISTED AS ASSIGNED.), much like telling them to ‘Wait here.’ in other games. Afterwards, I saved, via quicksave, THEN saved and quit. I made a backup save (just in case something derps out. Heavy Skyrim Mod User, backup saves are kind of mandatory for me, lol.). and then reloaded that world. I proceeded to ask them to follow me, using the option to have them do so when they are on guard duty. I walked 30 tiles, and they never moved. Note, she was set to follow me at 2 paces (so 2 tiles away.). So I was like ‘that’s weird…’. Had to fully dismiss her by ‘going our separate ways’ and then re-recruiting her to fix it.

The second occurance was when I swapped from one world, to another, (cuz I wanted to get back to my main Survivor on the main world I used.) and the npcs I have set as a ‘Buddy System’ for when I go out hunting, or looting, who are set as Guards, would also, not follow me. I’ve also had this same bug apply when they are already following me.

Yes, it can happen more frequently and consistently when swapping between ‘toons’ on the same world, but my occurrences were when I WAS USING THE SAME TOON ON A WORLD after swapping from a different world entirely, AND ALSO WHEN I HAD USED A DIFFERENT CHARACTER ON A DIFFERENT WORLD. So it’s definitely an NPC thing, which, NPC’s are already borked 9 ways from Sunday… a year from now… Extremely buggy.

the second occurance was likely bugged out because of the reason i explained.
cataclysm currently doesn’t play nice with multiple characters interacting with npcs