Ninja mod not working

For some reason the ninja mod isn’t working. Any insight into this problem?

No.

so does that mean that its broken for everyone/

IDK if this helps, but when I try to create a new character I get these errors before returning back to the title screen.

Nope. “No.” means “we don’t have any insight”, because:

  • We don’t know which version you’re using, so we can’t fix it or help you, since it works fine in other versions.
  • We don’t know what you mean by “isn’t working” since you did not tell us that, hence we can’t help you.
  • “Ninja mod” isn’t an officially supported mod (or no longer if it ever was), you’re more likely to get help from the mod author himself (the place where you’ve downloaded it).

It’s just going to be an endless guessing game without further informations.
I can and will try to help, but please do two things first: Read on this external site how to properly report bugs (especially the “It doesn’t work.” section), and leave the following informations:

  • Game version
  • Mod info (the id of the mod, along with when & where did you get the mod from)
  • Description of what isn’t working (I guess “back to the title screen”, as you’ve written later on?)

Awesome! Thank you for the insight​:grin::+1:t4:.
Game version: experimental 11491
Mod: ninja mod included in the cdda launcher (not sure where to find the mod I’d, please forgive me :pray:t4:)
The “problem” are the screenshots posted above. After the errors the game returns to the title screen and will not load the world and allow me to create a new character thereafter.

Please forgive me for my noobness🙇🏾‍♂️

Here is the only info I could find on the Mod

ok will do. thank you

Thank you very much for these information.

I can work with that.
The launcher uses a version from 2018 and points to this topic in the forum.

Unless I’m mistaken, this mod was made with lua in mind (the support for that was dropped a “long” time ago), but might be able to work if all the parts are removed that try to access lua.
All the other errors you’ve posted screenshots of should not prevent the game from loading, aside from the last one.
I’ll test it as soon as I get the time for it.

thank you much. ill do some digging and see what i can do as well!!

Alright, after trying to fix the mod (since multiple ID’s were missing), I had the idea to check if someone else already fixed it…
Welp, I could have saved myself some time… Looks like it’s in TheGoatGod’s Mod Compilation and in a state that works (at least partially, it does not return to the menu).

You’ll have to download the full compilation. After downloading and unzipping, you will find the mod folder in data/Unleash_The_Mods/mods/Ninja_mod. You will have to manually replace the version the launcher installed for you with that one (and restart the game).

I’m not sure (and actually doubt) that everything works as it should, but at least some stuff is in the game, and it shouldn’t crash…
Let me know if it works for you.

Ok thank you! Will do! I spent all night figuring out how to fix enough errors to get it working with my very limited understanding of coding. Even though it “worked” it was still busted (I probably made it worse lol). I did however learn quite a bit in the process! With that said my interest in coding has been rekindled. Is there a forum on here or a resource I can reference if I want to Tinker with creating mods or contribute to content?

that worked! thank you

Wonderful, I’m glad you got it working :slight_smile: .

We do have the #game-talk:the-lab section for mods, as well as #game-talk:the-toolbox for modding help on this forum and - depending on what you want to mod (JSON additions/modifications for the game or the source code in C++) - the game’s GitHub with helpful links like how to contribute, how to compile the game, and the doc folder contains a lot of information for JSON modding.