Main menu arrow crash

Okay, so, here’s the thing:
My character died due to a landmine. Holding 3, ran over a landmine, died. Noob mistake.
I watched his final moments, then pressed q and walked away. I came back and the screen was black, so I closed it and reopened the game, only to discover that pressing the left or right arrow crashes the game. I can press up and down, as well as the hotkeys to navigate the main menu, but not left or right. This immediately crashes the game. However, it only makes it crash on the main menu, including navigating beween loading different games and making a new character or a preset. However, in the pop-up menus for world generation it does not make it crash. I am using 7377.

Edit: Forgot to mention that the arrow keys also work ingame.

Which ‘Fullscreen’ option are you using in the Graphics menu? The game will sometimes crash or have menu navigation issues if you have that option set to ‘fullscreen’. It is generally recommended to use ‘Borderless Window’ instead as it is much more stable and fixes some of the crashing and menu movement key issues.

I’m not in fullscreen. I used the ‘set terminal size’ options to make it bigger, though. I didnt know there was a fullscreen option.
Also, I already tried removing the config to fix the problem, and it persisted.

I don’t know if you gotten it to work by now, but if not, check the debug log (Cataclysm\config\debug) for messages like this:

“Failed to open audio mixer, sound won’t work: DirectSoundCreate8: No audio device found”


14:20:14.702 SDL : src/sdltiles.cpp:2201: Failed to load audio file data/sound/Basic/menu_move.ogg: Audio device hasn’t been opened
14:20:14.702 SDL : src/sdltiles.cpp:2201: Failed to load audio file data/sound/Basic/menu_error.ogg: Audio device hasn’t been opened

it may have to do with an unplugged or broken audio device.
I just plugged my headphones in and it worked.