Is crafting bugged? No room in inventory

#1

Just tried the hybrid inventory build and i’ve got the same problem with the latest experiment build.

Started off as a convict in a house. Tear down curtain. Got strings and sheet. Try to make a keffiyeh, but says i’ve not got enough room in my inventory so drops an in progress 0% keffiyeh on the floor.

Are you saying I need something like a backpack to craft something that involes wrapping a sheet around my face?

Last experimental build I was using is 8740 “inventory room” was never an issue with crafting.

#2

I haven’t had this issue so I think it’s a problem with the hybrid inventory you mentioned. It might be best to bring it up to the mod creator.

#3

I thought it might be the mod, so I also tried a non-modded version (8765) and still getting the same issue.

#4

I’ve had this same issue, no room inventory, so the item drops to the ground at 0%, but if you pick up and wield the item you can finish it that way. Not sure if this is functioning as intended or not but it is annoying as you have to add extra steps, or else have a lot of open inventory space. I’m using a pretty basic CDDA, no inventory mods. Also if you fail building an item you’re left with the items in inventory but if you use the - key to build again it will try to pick up all new items and sometimes you’ll get the no inventory message again and drop the new item since the failed items are hogging all your space. That definitely doesn’t seem like it’s ‘working as intended’.

1 Like
#5

They’re changing the way batch crafting works. The batch item you are crafting has too much volume to be in your inventory. So once it drops to the ground, you can wield it by picking it up. Then activating the item to start crafting it.

The reason for this change is great in the long run. They are going to make it so you can craft for specific amounts of time. You could split a large crafting job into 1 hour a day for 10 days if you wanted to. So if something takes 10 hours to craft, you don’t sit there for 10 hours while going thristy or hungry. Not passing out while crafting. Not knowing if there is still enough daylight to finish the task before it fails and you have to start all over again.

The issue with the item dropping out of your inventory is also being worked on. They have been talking about making a workbench that would store the inventory for batch crafting. They have also thrown around the idea of allowing you to examine the batch item that falls on the floor and examining it to continue crafting.

You can always see what they are working on and ask question/make suggestions on discord or github.

Just remember, they’re working on it becoming a nice seamless system but everything needs testing. And testing is easier one small step at a time. They’ll get there.

#6

I wasn’t batch crafting though.

I dunno if something’s conflicting with batch and singular crafting somewhere then.

#7

Did the item you were crafting contain items that would fill your max volume on your character?

#8

It also happens when crafting one item if you don’t have enough volume in inventory to pick it up.

Idea is great, the only thing it needs IMHO is polish. (ability to craft unfinished items on the ground)

#9

Yeah, the sheet would have taken up too much room.

If tis is how crafting is gonna work now, it makes no sense.

To make a keffiyeh which involves picking up a sheet and wrpping it around my head, i’m gonna have to go and find items of clothing with enough storage, go back to the sheet just to pick it up and wrap it around my head.

If you have enough ingredients in front of you, why do you need room in your inventory?

Sorry if i’m sounding ratty. Been stuck indoors lately bored outta my head.

#10

Your argument about the keffiyeh makes sense. Remember, they just started working on this. This is the kind of feedback they need so that tweaks can be made. They are active in the forums. But if you want a more immediate response, you could mention this in discord, or make an issue on github.