How do I make an uncraftable recipe craftable?


#1

I was hoping someone could give me a rundown on how to make uncraftable items craftable? If I was just adding a new item I don’t think I’d have too much trouble but I’m worried about messing something up when it comes to items that are already in the game but aren’t craftable.

Hope this is the right catagory for this type of question and sorry if it’s been answered elsewhere.


#2

It needs to have a recipe, for one.

Also, it may require some leg-work to make it all work. I’ve been looking into another mod that seems to have issues with recipes (Salvaged Robots).


#3

I might be able to borrow the recipe from an older version of the game I still have so hopefully that won’t be a problem, is there anything else I need to do? I’ve been poking around a bit in the game files and the item json is in a folder called “uncraft”, would I need to remove it from there?


#4

The “Guide to Adding New Contet to CDDA for First Time Modders” starts with discussing how to add new recipes.


#5

like I said, if I was just adding something new I wouldnt be too worried, it’s that I’m trying to added a recipe for an item that’s already in the game but not craftable. If that isn’t an issue though I’ll get right on it :slight_smile:


#6

Yep, but turns out it’s the same thing. Adding the recipe will make the item craftable and that’s all you need to do (plus the recipe needs to make sense and you might need to prove that it makes sense with some sources)


#7

Some things don’t have recipes because they’re not supposed to be craftable. Some things don’t have recipes because the guy who introduced the item forgot to include a recipe (this happens a lot with my items).

All you can do is submit a new recipe and wait for feedback.


#8

I don’t think they will add back in power storages as a craftable item, but my character had this ability before I updated the game and I would like it back for at least that save. I’ve crafted over 100 of the Mk IIs during that playthrough and don’t like the idea of my character forgetting how.

DEBUG : Error: data/mods//CBMSbackbaby/Items.json: ???: tried to start object, but found ‘�’, not ‘{’

FUNCTION : bool main_menu::load_character_tab()
FILE : src/main_menu.cpp
LINE : 947

keep getting this error and not sure what I’m screwing up ><


#9

It means it’s looking for a { but it’s finding . . . whatever that other thing is. I don’t suppose you could throw the file on github or somewhere? Or, if your mod is literally just adding a recipe you could just put it here in the thread. You can use [code] (put your code here) [/code] to make a code block in the thread.

Unless I’m missing something, adding the recipe should be pretty basic. EDIT: Erm, that sounded mean. I just meant it’s probably an easy fix.


#10

No offence taken, I’m pretty new to this sort of stuff. Does this give you what you asked for? never really used github before.


#11

Yep. So, in the items file, you need to put a closing ] at the end.

In the recipes file, you need to add a [ at the start and a ] at the end.

That should be it.


#12

It worked!
Thank you and everyone else for the help, it’s very much appreciated.


#13

I’ve made the changes on github and added the modinfo JSON for anyone else that might want it at some point.


#14

I would like it back for at least that save

So if it doesn’t stick as a PR for the main game you can just modify the files locally and since it’s just json it will work for your game


#15

sorry but I don’t know what you mean by PR?


#16

Pull Request : a request to add your edit to the main game on github


#17

Ah, Honestly I doubt they will added CBM power storage recipes back in, it works fine as a mod since for the moment at least I only want it for that survivor, no need for temption for my other survivors and it’s here if anyone else wants it.

I can understand why it was removed, it made Mk I’s basically useless as anything other then crafting materials for Mk II’s, I have some 120+ Mk II’s installed on that character but only 8 Mk I’s.