Healthcare skill will not progress under any circumstance

No mods or anything. I noticed it was stuck at 0%, proceeded to read Big Book of First Aid, and I noticed that it did this

healthcare bug

I tried debugging a skillpoint into it to see if that would work, no dice. Any help would be appreciated.

Version?

0.E-9229-G6902525-DIRTY

I posted about it on git and apparently the same issue has happened for vehicles, as well.

I’ve never had a big bug like this on experimental before. Does anyone know if my save file will ever be usable again? Is there a way to fix it through save file editing, or something?

Save editing should be doable. However, if you don’t know why it happened the first time you don’t know if it will happen again. I’ll take a look see.

It wasn’t just health care, there were two or three other bugged skills as well. I put a fixed version of the .sav file for “Lemmy”. Extract and copy over old version in your save folder. I put it on the github because it’s easier that way (it’s tiny, so hopefully nobody will object).

Thank you so much! CDDA has the best community for a game I’ve ever experienced, tbh.

Hello,

I’m also experiencing this problem, It is not exclusive to health care skill and it’s pretty game breaking because it comes back even after manual fix.

Version: I returned to CDDA 2 days ago and pretty every one of my characters had some of their skills bugged so not sure if the bug was there before but it’s there at least since Wednesday.

  • if the skill is bugged you can see it in the save file, it’s exercise value will be a big negative number
  • it can reset your progress back to zero even if you gained some exp%.
  • you can “fix it” by editing the exercise value but it can just bug out again

Example from attached picture: character had a bunch of bugged skills including melee, fixed them by manual edit and continued playing, gained exp again. Got into a long fight with mi-go, checked my melee skill and it was reset back to 0%, exercise value in save file returned to it’s bugged state.

No idea what triggers the bug, I was just doing the usual early game stuff, nothing fancy.

Looking at that number, it’s almost certainly an overflow error.

At some point skill learning (and some other stuff) was ‘refactored’ by 1000. I’d guess that some code was messed up during that process. You could probably ‘downgrade’ to an earlier version of CDDA. Has anyone worked out exactly what build it stops working at? I’m on 11398 and I haven’t noticed any problems yet (but I haven’t been playing much recently).

not sure what that means but is there any way to prevent that from happening?

I’ve made a fresh install and upgraded to 11421 and it keeps bugging out :nauseated_face:
Doesnt seem like a lot of people are experiencing this, could it be related to my hardware or something?

I suspect it’s more likely because you’re using a more recent version than other people. Personally, I’m not going to update to the latest build before it’s fixed.

code bug. only thing you can do is play on older version or just wait till it is fixed. there’s a report about it already on github.

Hello again,
I’ve found a way to reproduce the bug : do any exp gaining activity while you have 1 focus and Albino trait. I’m still not sure if Albino is necessary or just provides the constant focus drain for the bug to occur.

I’ve tested it on 5 different characters and it always bugged out but only when I had the Albino. I’ve made a couple of non Albino characters, drained their focus to 1, did some exping and it didn’t bug out. I still think it’s related to focus not the trait per se but it’s just a guess.

If anyone feels like testing it on their setup you can do it in 2 min: make Albino character wilderness start, forage a few bushes to get a few survival %, wait on the sun for a hour to kill your focus, start foraging again with focus 1> bug should kick in after a min or so of foraging> survival exp is back to 0 and save file is corrupted (big negative exercise value).

1 Like

This might be confirmation bias, but all of my characters typically have albino, and I can now confirm I had three instances of this happening with different characters. I ended up just reverting to a build from a week ago, has not happened since.

Yeah, albino modifies focus directly, which caused it to become negative, and caused problems with the skill gain calculations.

I have this bug with a character who does not have the Albino trait. I started with Heroin Addict, which causes Focus to tank from opioid withdrawal.