Having trouble compiling on OpenSUSE Leap 15.2

I am getting strange errors while trying to compile. I use Terminal only with no X11. In the OS installation, I’ve checked all of the relevant dev tools. OpenSUSE 13.1 and 13.2 were able to build the game without issue.

I start by cloning the git repo:
git clone https://www.guthub.com/CleverRaven/Cataclysm-DDA
Then I cd into the Cataclysm-DDA folder and type make and hit enter.

Please make sure you follow the readme: Cataclysm-DDA/COMPILING.md at 6b8dd0058f2c011b0c2ea8d80679d70e2e594229 · CleverRaven/Cataclysm-DDA · GitHub

There is a list of dependencies that you need to have installed.

See ncursesw compile error on openSUSE Leap 15.2 · Issue #46689 · CleverRaven/Cataclysm-DDA · GitHub

Sorry for the late reply. I installed the dependencies that were listed but still get the same error. As a precaution I also did make clear and then make to ensure that everything was correct.

I tried downloading the latest build and I was able to run it without issue. Is it possible to download the build from the terminal? I can get the address from my cell if there isn’t a preset location.