GFX version terrifying slow


I just built gfx version and I noted that it is absolutely unplayable. When I press movement key, my character begins moving with 1-2 FPS. Options menu redraws in 5-8 seconds for each keypress. And all other gfx stuff works like that.

I use this command for build “make NATIVE=osx LOCALIZED=“ru” OSX_MIN=10.8 TILES=1 RELEASE=1 -j8 FRAMEWORK=1”

Enviroment - Macbook Pro, OS X 10.8.

Is there any way to boost up gfx version? Terminal version works well.

  1. What are your specs?
  2. Do you know how to use a profiler? The output of that could help figure out just what’s causing the slowdown.
  1. My specs is 2.3 GHz i7 8 cores + 8 Gb ram.
  2. No, I never used profiler for C/C++ on mac. But if you can tell me how to run it, I’ll get performance log for you.

Yes, try either “RELEASE=1” or CXXFLAGS=" -O3 "

I’ve had the RELEASE flag not work for me. By default, optimization is not turned on. The curses build is much faster with -O3 as well. Whatever command you use, you should see -O3 on most of the lines as it compiles the source. If you don’t see any -O3 flags anywhere, that is why your performance is so slow.

No. That’s not works. Performance still same. “-O3” was appear on each line of compiler command. Loading 30000-size world took about 1.5 minutes. Although the same world was loaded with about 5 seconds on text version.