Game crashing with custom fonts

So yeah, download 1910, haven’t tried 1900, but when I go to make a custom character it plain old crashes, doesn’t get anywhere.

I’m using VeraMono.ttf (and tried renaming to lowercase), and it is in the config fontlist, and my fonts.json looks like:

“fontblending” : false,
“fontwidth” : 12,
“fontheight” : 12
"fontsize" : 12,
“typeface” : “veramono”,
“map_fontwidth” : 12,
“map_fontheight” : 12,
“map_fontsize” : 12,
“map_typeface” : “veramono”

The start screen loads okay except the CATACLYSM thing is all screwed up. The viewport is smaller than my screen (I know about that issue) and I tried turning off graphics acceleration to no avail.

Ok, I switched the font to terminus and although the front message is still ok, the game still crashes.

I will add, starting the game with no viewport change does work, but no after changing.

I may have found particularly WHEN the bug hits:

All of my game settings were done, same Cata (I made a back-up of settings to verify) and up until I changed the viewport size does it started flipping out. At EXACTLY 1216 tall it flips out consistently(76 chars at 12x12).

Then it flips out at 75 sometimes (I can go into/exit the custom char menu, but it can crash). If I go to random char it threw a Microsoft Visual C++ error

Then I was testing at 70, and now as I tabbed through menus I get trapped at the profession screen because it hijacked my tabs… how am I supposed to deal with this?!

Edit: Ok, I’m supposed to use <> in that menu, good to know, but 70 doesn’t crash, while 75 can, and 76 always does.

Edit Edit: I added it to the git tracker.