Experimental BUGS* (Tried removing item from object which did not contain it)

Hello my Dudes of the internet.

I present you my problem.

Experimental Windows tiles both regular and x64
Basically the builds of the past 2-3 days.
Every one of this eventually leads to a crash/bug. Some are right after loading, some after a few minutes of running around a city.

No mods, Fresh install.

DEBUG : Tried removing item from object which did not contain it

FUNCTION : item visitable::remove_item(item&) [with T = item]
FILE : src/visitable.cpp
LINE : 531

I belive it’s this crash right here.

I’ve been playing CDDA for the past 2 weeks in stable 0.E.

My questions are the next:
is this a known issue
am i the only one experiencing this
is there a way i can fix this myself

I can ignore the messege and continue playing however I i figured I’d inform the forums.
If any other information is required let me know, however I’d imagine anyone can replicate this with little effort. Also I should mention that this might have happened early into my Stable 0.E playthrough but I wasn’t paying attention and skipped it without reading.

And with that, I return to the Cataclysm.

1 Like

I’ve been getting a ton of those (20-50 at a time) on world gen post-10582 and getting them periodically throughout gameplay, but they’ve never caused a crash for me on 10581-10590.

There are a few issues on GitHub about them and one that has the same message but may not be related so I assume people are aware of it.

Someone said they’ve seen it in the context of zeds reviving, and Magiclysm players have reported it when summoned items like the bow or magelight disappear.

In case it wasn’t clear.

I can just ignore this and continue playing. Not a crash just a bug. It does happen a lot, if I ignore once with space bar I get one of this errors every time I move one tile for long distances. If i do the Ignore all (I or i) they go away.

Edit. I did also expirience a particular one detached from a city.

Doing the hub quest, “destroy the robot”. Right after the robot got hit with the EMP the game gave me this error.

Same here. I was just concerned because the topic says “experimental crashes” and crashes are mentioned a lot in the initial post; I thought the issue might have escalated.

this is actually a bug i introduced int he pr preparing for nested containers. sorry.
I still have my nose in nested containers, but if that doesn’t fix all of them (no seriously, all of them) then i will look into the individual ones.


Well, it is called experimental for a reason.

1 Like

I have the same error on


But I can press space to ignore and nothing “seems” to be broken. So idk.

I get multiple errors while I’m sleeping, a few when dissecting (dialog says it takes 44min).

Normal exploring doesn’t seem to trigger it.

I had assumed this was a side effect of a slightly broken mod. But I’ve been having these exact errors every time I start my world, until I hit ‘i’ for the first time. They seem to pop up when zeds die and spawn stuff. Another time I’ve noticed this is while traveling into fresh mapgen. Sometimes they’ll pop up during long actions like crafting or sorting items, but I assume that’s zeds getting killed somehow in an area far enough away for them to not get to me and close enough to still be in the reality bubble. It never crashes the game, in my experience, but I’d bet it’s at least partially responsible for some of the slow downs I’ve had on 0.E. Even when ‘ignored’, I imagine this is eating up some cycles. I play with 190+ mods active, haven’t updated since 10587. Hope this correlates with someone else issues and helps narrow things down.

Along with getting this bug, I’ve noticed other strange behavior with containers, on a save that’s been updated from Stable 0.E to Experimental.

Consuming from a container empties it like normal, but Unloading some liquid containers fires this error. Afterward, the Unloaded container is treated as empty, but is still marked as a “plastic bottle of [liquid name]” but with no volume listed. It can also still be Unloaded (transferring no liquid, and firing the error again).

However, on any save and reload, these buggy Unloaded liquid containers will refill their contents to full. And the container they were poured into will retain the liquid from before, effectively making any liquid infinite.

I’m guessing this is all related to some WIP reworks for nested containers that I’ve seen on the Git for CDDA. But just adding this because I hadn’t seen this behavior mentioned yet!

I mean, KorGgenT literally said it was his fault and caused by the work he does for nested containers:

So… Blame him! Shame him! To the pillory with him! Or… well… better not, we need him to fix this :relaxed: .

Past tense, don’t ya know?

Hey, dudes! Me, and my friend I spot a huge bug in the 0.E version.
To be short - there is no way to increase vitamin B12, C, and calcium upper than 0.
Win 7 64-bit, 6GB operative memory.

I hope for your help, because it really makes the game broken.
P.S. Sorry for bad English :slight_smile:

A fix was merged just couple minutes ago, we’ll see if it works. It is/was caused by intermediate pr which is a prelude to a new container system.

Good thing it doesn’t give you any debuffs then :smiley:

1 Like

It does. The character coughs every seckond, bones breaks, and he is getting cold really often. a speed of healing is much slower. I wouldn’t disturb you if it wasn’t a big problem.

Yeah I’m getting the same issue with this error message.

This doesn’t sound “past” to me. It’s known to not be caused by the mods, so why mentioning it? It’s not necessary to narrow it down to an update as it is already known which PR actually caused this. Don’t ya know :stuck_out_tongue_winking_eye: ?

I would suggest you open up an new topic about this problem in The Garage, it makes it easier to keep follow specific problems.

For now, you can’t get higher than 0. 0 means you have no lack of vitamins. Values far below 0 is where problem start.

For now, the vitamin system is not in place. Your symptoms are not caused by vitamin deficit. You might be sick (check status screen with “@”) or you have parasites (take antiparasitic drugs). Your health value is low, you can increase it and the health modifier in the debug menu or by eating healthy.

No, no I did not know and I’m not sure why exactly you’re harping on about it, tbh. Are you trying to make me feel bad for participating in the discussion or what?

If that is true, it is great. Thanks for help:)

It is fucking awesome. No more coughing and pain in venues! Great thanks to you dudes!!!