ERROR: Game Is Unable to Write Its "Options.json" File

Okay, so, first post, hello fellow survivors. I’ve been playing Cataclysm for a little while now, and please allow me to take this small opportunity to say that I effing love this game. Anyways, on to the issue…

I’ve been playing version 0.E-2 (tiles) with no issues at all, but figured I wanted to update to the newest (tiles) version of the game. So I go and download it like I had before, unzipped it and tried to launch it from the exe (as I had before with 0.E-2) and as soon as it had launched it gave me the following error message:

So there it is. It happens every time I launch the game, immediately. I do not see the title screen or anything, and the only way I can close it is by forcing it (i.e. Alt+F4 or Alt+TAB’bing and closing the window from the start bar, or task manager). I have extracted it to my Desktop (same as the old and still-working version), and I have even given every executable file I can find administrative access, and even tried closing any/all folders that had that file in their path (to make sure it wasn’t thinking that the files were in use), yet it simply refuses to run.

I have tried this with both the current stable, and experimental builds (I have all the exact info below, including my OS, the versions, etc), and it gives me the same error on both. Now, I have noticed that the readme describes methods of compiling the game, and I am forced to wonder if this is the reason it’s not working. However, I don’t seem to recall ever needing to compile the old version, which, again, still works. Anyways, here is all (I hope) of the relevant info:

How to reproduce: Not 100% sure what conditions need to be met. All I have to do is try to launch the “cataclysm-tiles.exe” file directly after extracting the game’s folder to my desktop.

My PC (yes I know it looks like Frankenstein’s monster, but it gets the job done lol):

  • Windows 10 (pirated version, so not sure specifically what update I’m using)
  • 16GB RAM
  • 2TB HDD, 1.5TB SSD (Game as well as OS are currently on HDD)
  • Radeon RX 580
  • Intel i5 3570K (Quad-core @ 3.4GHz)
  • Asus P8H77-V LE Motherboard

The following are copy-and-paste’s of the “version.txt” file from the game’s folder:

Old version of C:DDA (that still runs):

  • Platform : Windows_x64
  • Graphics : Tiles
  • Build number : #10479
  • Build version: 0.E-2
  • Major version: 0.E

Current stable version (that is giving me this error):

And here is the info for the experimental version if that’s relevant (I got the same exact error with this one, too):

**After re-reading this before posting I just noticed my version.txt files for stable and experimental look weirdly similar and also at the same time very different from the working stable version I have. Was the format of this file changed recently, or is it actually possible I downloaded an experimental version of the game that was labeled as stable?

Any help with this would be greatly appreciated, as I have found no mention of this specific issue across the entirety of the internet, other than some old forum post from a few years ago claiming that it had been fixed in a version earlier than my “old” one. Clearly something since then has stirred it up, unless I’m just being stupid by not doing any of the compiling stuff, but that’s another story.

Anyways, if you made it all the way here, congratulations, I know I can be long-winded, especially behind a keyboard. But I just wanted to make sure there was enough details for people to figure out what was going on. I appreciate anyone who does take the time to help me figure this out, and I’ll see you guys in the Cataclysm. Peace.

P.S. - I have actually tried to compile the game with the msys2 console, but it didn’t seem to work. It couldn’t find a file, then it kind of imploded on itself, i.e. it said “pacman is not a recognized command or path” or something to that affect. Not super familiar with console-type stuff, I’ve used Linux before and have written batch files on Windows, and I followed the readme instructions to the letter, but still not sure if I just did it wrong.

Can’t think of anything specific, but maybe a permissions issue? I’ve heard that some of the game files have been moved to a different location to avoid that in newer versions, but that hasn’t been my experience; however, I’ve got it installed on a different drive from the system drive.

The download version from the website or the GitHub release page is already compiled, if you’d downloaded the source code you’d have to compile it first (there would be an src folder and no exe file).

No, version cdda-windows-tiles-x64-2021-07-03-0512 is actually the stable Frank one.

Especially in error reporting, this is very welcome!

Yes, I’ve run into this issue before (deliberately).
As far as I see, the error you’re experiencing happens because it can’t create (or access in general) the options.json file.
That the number changes is “normal”, as this is just a temporary file that exists in your temp folder and it fails to move it over.

There could be many reasons why it can’t create that file. Most likely it’s a permission issue, as MrAbrahms though of. Since you’ve extracted it to your desktop (and most likely still have it there), this is very likely, as the desktop is usually protected on Windows operating systems.
The other possible reason would be that your drive is full and it can’t write any more data. I don’t expect this to be the case, but I still decided to mention it.

As for possible ways to fix it (assuming it’s a premssion issue):

  • The easiest way I can think of would be to move it to another location on your drive (and maybe create a shortcut to the folder on your desktop).

  • But if you’d prefer to keep the folder on your desktop, you will need to check/give the folder and all it’s containing folders/files read and write permission (for the current user/admin/system). Allowing it to run as admin is most likely not enough if it’s lacking the necessary permissions in the first place.

  • Another possible way would be to copy-paste the existing config folder from your previous version. However - while this might allow you to start the game - I’m pretty sure you’ll be back to square one once you’re trying to create a world.

If you do have it on your desktop, it might be worth to move it somewhere else (even if you want to keep it on your desktop) and give it a try to see if it produces the same error.