Dropping weapon somehow takes several minutes

I have a character who specializes in unarmed combat. I was being chased by a security robot. At this time, they are in perfect health and at about half stamina. They are wearing nothing with encumbrance value except a fast-draw holster, a leg ammo pouch, and a sheath.

I apparently didn’t have time to line a up a shot with my rifle (a half-loaded SKS from a basement), no matter how far away I was or what aiming mode I used. This in itself is bullshit, because I can outrun the thing with a movement speed of 46, and lining up a shot was supposed to take around 230 turns at the longest, but let’s ignore that for now.

So, I decided to just drop the rifle on the ground - which is supposed to be an instantaneous action - and punch the thing. Unarmed was nerfed at some point, but I can still kill pretty much anything but a shoggoth or a super juggernaut.

I got turned into swiss cheese and had to interrupt this action, which is supposed to be instantaneous. This happened several times. The robot would catch up and start shooting me before I dropped it, no matter how far away I was.

I turned on my cloak and tried dropping it again. At this time, my character has a full battery charge of 3000. Healing Nanobots is activated, but - since this action is supposed to be instantaneous - that shouldn’t matter.

My character takes so long to drop the rifle that my battery charge completely runs out, cloaking shuts off, and I start getting shot again. Both healing and cloaking drain energy extremely fast, granted, but it still would have taken several in-game minutes for this to happen.

So after I got finished screaming bullshit and alt+F4’d, I had my character put on a wrist watch and timed how long it took to drop a rifle.

0 seconds. Every time.

I tried this with every long gun I had available, and the SKS using debug.

I also spawned a security robot using debug, and tried both dropping the gun and taking a shot.

The first attempt crashed the game when I tried loading it with an M67 round. As you do. So I tried the other type.

Both actions were successful. Dropping it was instantaneous, and at the same distance as before, I was able to pick up two rounds, then load them both individually and take two fully aimed shots to kill it before it even got close enough to shoot me.

There are apparently two security robots with the same description, and this happened with both of them.

And at this time, my character was in severe pain and tired, so aiming took longer. 271 turns.

Just…what is even happening with this game anymore

1 Like

Too bad it’s not reproducible :confused: Tough to troubleshoot that. The current flakiness is just the aftershocks of a MASSIVE change to turn lengths, from 6 seconds to 1 second. It will take a little while to shake out all the side effects of that change, which is why the, self-admittedly, experimental version of the game is currently unstable. You’ll have that from time to time in games that are developed like this one is. Among your many choices, you could play the stable version of 0.D for awhile, til the current instability subsides.

In short, the current situation has happened before and will happen again, if we’re lucky. Close your eyes and think of England, this, too, shall pass.

Hugs and headpats
I’m here for you if you need me. :stuck_out_tongue:

Is that what’s going on? I certainly hope so, cause this happens completely at random and it’s always in the worst possible situations. This character has an effective Dodge of 25.3, so most of the time it’s just annoying, but sometimes it really screws me over.

1 Like

It seems like. I don’t keep up on things like I used too, but I recently went through github and a large portion of bugs and fixes lately have been related to turn length and things derived from that. I think the initial switch to 1 second turns was almost a ‘Leroy Jenkins’ style dive into insanity. It certainly had unforeseen effects. Give it time, things’ll get better.

P.S. If you can find a way to reproduce the bug, we can get a bug report on github. Reporting it in a non-reproducible way won’t get much attention.


I mean, the builds are called Experimental for a reason.

Also, the best excuse to fix stuff is when everything breaks.

1 Like

I know it doesn’t help but I’ve observed it taking time to drop stuff, mostly when the character is over weight capacity. There are lots of things that lower strength/weight capacity. I haven’t really taken a hard look at it though so no issues on github from me.

Weird thing that happened to me was that suddenly using my sling to throw pebbles took a lot of time, was aiming at a zombie at max range (18) and then got the pop up that i was being attacked, and it was that same zombie, maybe is related