Did I mess something up, or is this a bug? I can't reopen the tour bus aisle curtains

I’ve been playing a few weeks, without spoilers, and been enjoying the experience a lot. It’s hard to believe Rogue turned into this!! Unfortunately avoiding spoilers has meant avoiding the how-tos most of all. I did a search of the site using the magnifying-glass search function - nothing useful. (Strangely, when I typed my question here the “Your topic is similar to…” box (a great idea!) provided very different results than my own search - what’s up with that?)

My problem seems like maybe a bug (0.E-3, so I’d think it would have been discussed already) but it could be an interface issue. It seems like the answer would be something I’d notice “if I were there” considering what I’ve tried so far, and the interface options I know about, so I’m no longer worried about getting spoiled here.

I discovered vehicle construction, making a no-wheel car battery recharger by adding a wind turbine to a frame that I found, which led me to vehicle repairs. Very cool, nice progression of in-game discovery! I found a recharging station in another vehicle and haven’t figured out how to get it attached to my recharger vehicle yet (I think I’m close, so no spoilers there please!), but in the meantime, to try it out, I added a wind turbine to a tour bus and added the recharging station to the bus. Worked great! And of course power means working kitchen, means more …

Then I discovered the aisle curtains, and pulled them closed with the ‘c’ button, and then found hitting the ‘o’ key results in a “nothing to open here” message. For ‘c’ to work but ‘o’ not seems buggy to me, but maybe not. The game does have some newbie-sensitive interface issues after all.

Now I’m finding I can’t reopen the aisle curtains at all. The description when I examine the vehicle square says I should be able to open and close them from the driver’s seat, but I can’t. There is no aisle curtain control among the other electronic controls, though I don’t remember if they were there before, and I’m seeing no other controls anywhere else.

I’ve tried to mend but the vehicle has nothing to mend.

I’ve tried uninstalling the charging station (maybe the dashboard has a limited number of spaces).

I’ve tried uninstalling and re-installing the aisle curtains (maybe order of installs affects what shows up on the controls).

I’ve tried repairing the dashboard, and everything else at the driver seat, except the XX security system (maybe controls disappear when damaged, but that’s something I should be able to “see” when I examine or attempt to mend/repair it).

I’ve tried repairing everything between the driver seat and the curtains (logically a ridiculous thing to try - installing wind turbine and recharging station at arbitrary places automatically made the connections, so continuity of aisles/frames should not apply).

I’ve tried adding aisles (both directions) over the exposed frames at the aisle curtain locations.

So now I’m stumped, and my avatar has spent the entire day in the heat, literally virtually naked AND with her internal climate control running full blast (She’s just upset she hasn’t been able to figure out the whole clay problem. I’ll let her try out those grenades on that skeletal monstrosity this evening and she’ll be fine.)

So am I banging my head on a bug here? Is there another control interface I should know about, or something else I’m missing?

stand near the tile with curtains, 'e’xamine, press corresponding direction key?

Currently mending can only fix engines if they have a malfunction(or several).

Thanks, I forgot to mention that.

'e’xamining the aisle curtain lets me peek through the closed curtains, but not open or close.

It is by my standards. And I can confirm that this bug exists in 0.E-3.
I’ll check to see if it got fixed in a later version.

As for a way to fix this for your game…

It actually states it can do so if there’s a door motor installed on the same tile as the curtain is: (A door motor allows you to remotely open or close it from the vehicle controls.)
And I’ve just checked it, it works (after installing the motor and having power in the vehicle, choose Control [v]ehicle or Control multiple [E]lectronics and then Toggle [D]oors).

As for the recharger - no spoilers - you might want to check the description when trying to install it on a vehicle tile as well, as it contains a hint… :wink:

Thank you! When I read that description I interpreted it to mean a door motor WAS installed (with the curtain), but my avatar (aka a little voice in my head) did mentioning how odd it was for the description to be so specific about a door motor. And come to think of it, when I uninstalled and reinstalled the curtain, there was no motor!

Well done. Thank you!

It’s still silly that you cannot open curtains by hand, only by motor. They don’t weigh a ton, after all.

1 Like

True, the descriptions are a bit confusing sometimes.
I’ll take a note, maybe it would be better to phrase it like A door motor would allow you[…], as it could clear up some of the confusion.

That’s why I confirm it’s a bug.

I’ve also tested it in one of the recent versions (a few days old) and it still exists there.
Also, there’s no bug report on GitHub on that yet, as far as I can see. I’ll search a bit longer and if I can’t find one I’ll create one (unless someone else wants to do that).

Thank you for reporting this bug, @bug.


Here’s the bug report…

Thanks for submitting the bug report. I noticed something that’s probably related. I installed curtains over the existing bus windows, and the curtains also have the door motor option. I 'c’losed the curtains at night so had no visual indication that they closed (no change in light, no visible curtains), and the same 'o’pen command resulted in the same nothing to open here message.

However, I tried again in the morning when a change in light from outside would be obvious. ‘o’ again gave me the “nothing to open here” message, but hitting the arrow toward the curtain did open the curtain, based on the change in light inside the vehicle! So the issue doesn’t seem to be that the curtains are opening and closing incorrectly, the only error is that the “nothing to open” message is showing up when it shouldn’t.

It would be nice to have some visual cue that the windows/curtains are open/closed though, as we have for house curtains.

EDIT: Maybe not the same. Yes, the “nothing to open” message shows up, but with the window curtains they definitely actually do open, and there is also a “you opened the tour bus curtains” message as well (but no “you closed the curtains” message when you close them). With the aisle curtains I really can’t see any indication that the curtains actually open when I try the same thing, and there is no success message either way.