Current experimental not working


#1

I just got back to playing. I can’t start a new character in the current experimental build, 7049. Last build I could use was 6488. How can I find in between experimental builds, like say experimental 7000 so that I can see which experimental versions breaks my game?

I’m playing on Android btw, but it always worked fine with the experimental builds before. Like I said 6488 worked fine.


#2

There hasn’t been a new android version since last June. How exactly are you playing current experimentals? Also android is unsupported. For android support, post in the Android thread.


#3

You can just copy the experimental files to the root of the 0.c copy on Android and it works just like normal. However there are recent errors popping up with experimental 7049.

Either way, I’m asking where I can download older experimental versions. So I can fix this problem myself, or at least locate what build breaks it.


#4

Backup savegames, clean app files, reinstall app and restore savegames. They are not neccessary will be working, but you can try.


#5

Share it! Share it! Share it!
(Guess i know now why shareit’s called shareit)


#6

Well, if you actually go to the experimentals download page you’ll see the last 20 builds. I don’t think they archive anything further back than that.


#7

Exactly. They only go back to the last 10. Which is why I’m seeing if anyone can tell me where to find old ones. Or possibly post a link to a zip of one of the older ones? Say like 6800-6900 or so.


#8

I think your best bet would be to see who forked the project on github around the time of those versions, and compile off the fork. I don’t think there’s a master backup. You might get lucky and find a player who sees this before updating who hasn’t played in 6 months.


#9

Ok, that’s a good idea. I’ll see if I can figure out how to locate derivative forks as well as compile since I’ve never done either of those. I understand the concept, but not the practice.

The other unfortunate thing is that my phone is significantly more powerful than my laptop, but idk how possible compiling is on Android. Woo…!

I love this game so much. So I have to figure out how to keep playing it on my phone cuz the Android port is actually extremely accessible IMO. I almost prefer playing on my phone since I can do it literally anywhere, and it’s faster than my laptop like I said.


#10

Good luck on that. Github won’t even load the forks because there’s over 1000 of them.


#11

Here’s one from October:


#12

You’re just looking for old versions of the data and mods to plug into the Android version? Just install Git, Git clone the repo, right click on the folder where you cloned it, and select “Git GUI Here.” Click on the menu “Repository” and select “Visualize master’s History.” Then select the commit you want to use. The date of the commit is shown in the right hand column and should give you an idea of which to pick. Right click on the commit and select “Create new branch” and name your new branch. Close that window and go back to the Git GUI and open the “Branch” menu and select “Checkout” (or just press Ctrl-O). Select the new branch you created and press the “Checkout” button.

This will reset all the source and data files to the commit you selected. You can then copy the data folder to your Android installation.


#13

Sick man. This is something like I was looking for. Hopefully I’ll be able to figure it out with this.


#14

This is the code #6999 is based on:

Try:

git reset --hard 1cfdd0a5cb618ee74c5c646ccd199e279004a0a2

That should rewind the repository to the commit above, which will allow you to compile a game mostly identical to #6999. narc0tiq has a downloadable dependency bundle for compiling Cataclysm in the Cataclysm directory of their dev.narc.ro site named WinDepend.


#15

Oh you’re using the new data files with the old executable? That will stop working eventually for sure, we change the layout of json data in the game engine on a regular basis.


#16

I’m actually updating the executable to the new ones in the experimental updates. However I am running into some small json formatting issues anyways. First debug error is the inability to recognize the anatomy.json.

These issues are really making me want to learn how to code and compile, I’ve always wanted to get involved more in cdda development. This might be the push I need.