Console version worked, SDL version doesn't

The thread below mine is similar but I didn’t want to hijack his thread so I apologize for any inconvenience or posting incorrectly ahead of time.

For the last week I have played the ascii version of 0.A, US English. I compiled it myself. I decided tonight that I wanted to try out “Retrodays” tileset as my first. I attempted to compile the sdl version with no luck. I then erased the files I had in home, downloaded the precompiled files and still cannot get the sdl version to launch. It hangs with a black screen in terminal.

Lubuntu 14.04

Bump! No one knows? Do i need to do anythig specific to the precompiled files before running them? Can anyone point me to more detailed instructions for getting this to work? (The wiki is extremely vague for sdl) Any guidance at all?? I know I’m new to this site and game but I still would like some help if someone isn’t too busy to give it.

Maybe there is a dependency that I haven’t installed that needs to be…Anyone know the full list of necessary dependencies?



this is what i get when attempting to run ./cataclysm-tiles:
*** error in `./cataclysm-tiles’: double free or corruption (fasttop): 0x09ae66f8 ***

a google search showed this to be a C coding bug

is there anything that can be done on my end? I downloaded the file multiple times and recreated the problem everytime…mods? devs? anyone out there with a clue?

First, there’s a workaround, launch as MALLOC_CHECK_=0 ./cataclysm-tiles

This is a bug in the font-loading library freetype, see for the gory details.

Thank you for that information and gory indeed. Perhaps I should have also included that my OS is 32bit on an old laptop (my “programming laptop”). Runinng that command gives me the same result => black screen of death. I can’t help but to feel like I’m missing something in all of this…

edit: btw when i say black screen…it’s just a blank terminal…

It sounds like you have another issue unrelated to the double free thing.
The dependencies are:
LUA5.1, freetype, SDL2, SDL2_ttf, SDL2_image, SDL2_mixer, gettext.

i appreciate your help but it doesn’t look like it’s going to happen. At one point i was able to actually load the game but it looked like a bunch of jumbled tiles and half the mennus were missing and the title page had no color. after recompiling over and over, i cant get it to load.


I got it working. 0.o

I am using the latest git clone. This is the ONLY way I can get it to work.

In order for this to happen, I had to load into the game via ./cataclysm and make changes to some settings (software rendering, terminal width & height, tileset), save them, then close the terminal. Re-open the terminal and load via ./cataclysm-tiles…and wala.

It took A LOT of messing with the settings in order for this to work. I literally had to turn a feature off and back on just to get the game to realize that the terminal was in fact at least 80 x 24. Same with fullscreen. It didn’t recognize the defaults.

I will say that the retrodays tileset that comes preinstalled runs really slow on my pc…the rest run fine. That’s unfortunate because retrodays is the one I want to try…I think it may be out of date after a quick look at the retrodays download page.

Thanks again kevin for helping me get all the necessary dependencies!